lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 19 Feb 2015 04:23:01 +0900
From:	OGAWA Hirofumi <hirofumi@...l.parknet.co.jp>
To:	Alexander Kuleshov <kuleshovmail@...il.com>
Cc:	linux-kernel@...r.kernel.org
Subject: Re: [PATCH] fs/fat: remove fat12_ent_blocknr and use fat_ent_blocknr instead

Alexander Kuleshov <kuleshovmail@...il.com> writes:

> There is only one difference between fat12_ent_blocknr and fat_ent_blocknr
> functions in bytes calculation. Let's add bits checking to fat_ent_blocknr
> instead code duplication.

I guess, fat12 (very small volume size) is uncommon to be used now, and
there is no way to switch fat12 <= fat16/fat32 at runtime. It is why has
special handler, i.e. avoid overhead to fat16/fat32 by fat12 code.

Thanks.
-- 
OGAWA Hirofumi <hirofumi@...l.parknet.co.jp>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ