lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 20 Feb 2015 23:50:12 +0000
From:	Al Viro <viro@...IV.linux.org.uk>
To:	Andrew Morton <akpm@...ux-foundation.org>
Cc:	Konstantin Khlebnikov <khlebnikov@...dex-team.ru>,
	linux-mm@...ck.org, linux-kernel@...r.kernel.org,
	linux-fsdevel@...r.kernel.org, Dave Chinner <david@...morbit.com>
Subject: Re: [PATCH] fs: avoid locking sb_lock in grab_super_passive()

On Fri, Feb 20, 2015 at 03:07:31PM -0800, Andrew Morton wrote:

> - It no longer "acquires a reference".  All it does is to acquire an rwsem.
> 
> - What the heck is a "passive reference" anyway?  It appears to be
>   the situation where we increment s_count without incrementing s_active.

Reference to struct super_block that guarantees only that its memory won't
be freed until we drop it.

>   After your patch, this superblock state no longer exists(?),

Yes, it does.  The _only_ reason why that patch isn't outright bogus is that
we do only down_read_trylock() on ->s_umount - try to pull off the same thing
with down_read() and you'll get a nasty race.  Take a look at e.g.
get_super().  Or user_get_super().  Or iterate_supers()/iterate_supers_type(),
where we don't return such references, but pass them to a callback instead.
In all those cases we end up with passive reference taken, ->s_umount
taken shared (_NOT_ with trylock) and fs checked for being still alive.
Then it's guaranteed to stay alive until we do drop_super().

I agree that the name blows, BTW - something like try_get_super() might have
been more descriptive, but with this change it actually becomes a bad name
as well, since after it we need a different way to release the obtained ref;
not the same as after get_super().  Your variant might be OK, but I'd
probably make it trylock_super(), to match the verb-object order of the
rest of identifiers in that area...

> so
>   perhaps the entire "passive reference" concept and any references to
>   it can be expunged from the kernel.

Nope.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ