[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <1424771583-4404-1-git-send-email-thloh@altera.com>
Date: Tue, 24 Feb 2015 01:53:01 -0800
From: <thloh@...era.com>
To: <dinguyen@...era.com>, <robh+dt@...nel.org>, <pawel.moll@....com>,
<mark.rutland@....com>, <ijc+devicetree@...lion.org.uk>,
<galak@...eaurora.org>, <devicetree@...r.kernel.org>,
<linux-kernel@...r.kernel.org>, <linus.walleij@...aro.org>,
<gnurou@...il.com>, <grant.likely@...aro.org>,
<akpm@...ux-foundation.org>, <davem@...emloft.net>,
<gregkh@...uxfoundation.org>, <joe@...ches.com>,
<mchehab@....samsung.com>, <crope@....fi>,
<linux-gpio@...r.kernel.org>
CC: <thloh.linux@...il.com>, <thloh@...era.com>
Subject: [PATCH v10 0/2] drivers/gpio: Altera soft IP GPIO driver
From: Tien Hock Loh <thloh@...era.com>
Adds a new device tree binding and driver for Altera soft GPIO IP.
The driver is able to do read/write and allows GPIO to be a interrupt controller.
Tested on Altera GHRD on interrupt handling and IO.
v10:
Updated conflicting device tree parameters
Removed unused headers
Used macro instead of magic numbers for ngpio
Code readability cleanup using ?: and temporal variables
Removed leftover garbage and unnecessary function calls
Checked bgpio_init but unusable because Altera GPIO may not be a multiple of 8 bits
v9:
Removed duplicated initialization on set_type using temporals to improve code readability in calling generic_handle_irq Using ?: ternary to reduce code size
v8:
Using for_each_set_bit
added const for struct definition
removed naggy pr_err
sort alpha header
remove unused macros
use fixed width data types instead of unsigned long whitespace issue fixes removed _relaxed function for better compatibility across different CPU changed irq_create_mapping to platform_get_irq updated implementation to use gpiochip_irqchip_add reserve interrupt-cells number 2 in device tree binding for future use remove confusing sections on devicetree bindings Added tristate Kconfig help text
v7:
used dev_warn instead of pr_warn
clean up unnecesarry if else indentation
v6:
Added irq_startup and irq_shutdown
changed bitwise clamping style
cleanup bitwise operation to improve readability change naming of mapped irqs from virq to mapped_irq
v5:
dispose irq_domain mapping correctly
update optional binding description in binding docs
v4:
added vendor prefix to devicetree binding for IP specific properties using MMIO GPIO helper library instead of manually map PIO to memory altera_gpio_chip inline struct documentation to kerneldoc using dev_ print to print a better failure message
v2, v3:
Do not reference NO_IRQ
Updated irq_set_type to only allow the hardware configured irq type
Tien Hock Loh (2):
drivers/gpio: Altera soft IP GPIO driver device tree binding
drivers/gpio: Altera soft IP GPIO driver
.../devicetree/bindings/gpio/gpio-altera.txt | 43 +++
MAINTAINERS | 6 +
drivers/gpio/Kconfig | 10 +
drivers/gpio/Makefile | 1 +
drivers/gpio/gpio-altera.c | 374 +++++++++++++++++++++
5 files changed, 434 insertions(+)
create mode 100644 Documentation/devicetree/bindings/gpio/gpio-altera.txt
create mode 100644 drivers/gpio/gpio-altera.c
--
1.7.11.GIT
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists