[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150304173551.7cb93917@notabene.brown>
Date: Wed, 4 Mar 2015 17:35:51 +1100
From: NeilBrown <neilb@...e.de>
To: Pavel Machek <pavel@....cz>
Cc: Tony Lindgren <tony@...mide.com>, Felipe Balbi <balbi@...com>,
Kishon Vijay Abraham I <kishon@...com>,
linux-omap@...r.kernel.org, lkml <linux-kernel@...r.kernel.org>,
GTA04 owners <gta04-owner@...delico.com>
Subject: Re: [PATCH 3/4] usb: phy: twl4030: add support for reading restore
on ID pin.
On Mon, 2 Mar 2015 22:04:31 +0100 Pavel Machek <pavel@....cz> wrote:
> Hi!
>
> > The twl4030 phy can measure, with low precision, the
> > resistance-to-ground of the ID pin.
> >
> > Add a function to read the value, and export the result
> > via sysfs.
> >
> > If the read fails, which it does sometimes, try again in 50msec.
> >
> > Signed-off-by: NeilBrown <neilb@...e.de>
> > ---
> > drivers/phy/phy-twl4030-usb.c | 63 +++++++++++++++++++++++++++++++++++++++++
> > 1 file changed, 63 insertions(+)
> >
> > diff --git a/drivers/phy/phy-twl4030-usb.c b/drivers/phy/phy-twl4030-usb.c
> > index 023fe150c7a1..759950898df9 100644
> > --- a/drivers/phy/phy-twl4030-usb.c
> > +++ b/drivers/phy/phy-twl4030-usb.c
> > @@ -374,6 +374,56 @@ static void twl4030_i2c_access(struct twl4030_usb *twl, int on)
> > }
> > }
> >
> > +enum twl4030_id_status {
> > + TWL4030_GROUND,
> > + TWL4030_102K,
> > + TWL4030_200K,
> > + TWL4030_440K,
> > + TWL4030_FLOATING,
> > + TWL4030_ID_UNKNOWN,
> > +};
> > +static char *twl4030_id_names[] = {
> > + "ground",
> > + "102k",
> > + "200k",
> > + "440k",
>
> New /sys files should be documented somewhere...?
Preferably with the code...
>
> Does it make sense to change "440k" -> "440KOhm"?
Interesting question. I prefer to avoid including units in files - bare
numbers is better. But there is no number to match "floating" unless I spell
it out as "infinity", and wouldn't be helpful.
Certainly "K" would be preferred over "k", and given that I have "ground"
and "floating", it is more consistent to include the "Ohm"....
These are really names, not measures of resistance. The data sheet calls
them:
ID_RES_FLOAT (or sometimes ID_FLOAT)
ID_RES_440K
ID_RES_200K
ID_RES_102K
ID_GND (or sometimes ID_RES_GND)
So using those names is defensible.
I think I'll change them all to upper case, but leave out the "Ohm".
My justification is consistency with the data sheet.
>
> Plus I guess you need to update Documentation/
I guess I'll need to give in to this eventually :-)
>
> Acked-by: Pavel Machek <pavel@....cz>
>
Thanks,
NeilBrown
Content of type "application/pgp-signature" skipped
Powered by blists - more mailing lists