[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <54FD4AEA.6000507@rock-chips.com>
Date: Mon, 09 Mar 2015 15:25:30 +0800
From: yakir <ykk@...k-chips.com>
To: Daniel Kurtz <djkurtz@...omium.org>
CC: David Airlie <airlied@...ux.ie>,
Russell King <rmk+kernel@....linux.org.uk>,
Philipp Zabel <p.zabel@...gutronix.de>,
Fabio Estevam <fabio.estevam@...escale.com>,
Heiko Stübner <mmind00@...glemail.com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
dri-devel <dri-devel@...ts.freedesktop.org>,
Douglas Anderson <dianders@...omium.org>,
"open list:ARM/Rockchip SoC..." <linux-rockchip@...ts.infradead.org>,
Rob Clark <robdclark@...il.com>,
Daniel Vetter <daniel@...ll.ch>,
Stéphane Marchesin <marcheu@...omium.org>,
Andy Yan <andy.yan@...k-chips.com>,
Shawn Guo <shawn.guo@...aro.org>,
Mark Yao <mark.yao@...k-chips.com>
Subject: Re: [PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style
On 2015年03月09日 15:05, Daniel Kurtz wrote:
> On Mon, Mar 9, 2015 at 12:42 PM, Yakir Yang <ykk@...k-chips.com> wrote:
>> - const struct dw_hdmi_mpll_config *mpll_config =
>> - hdmi->plat_data->mpll_cfg;
>> - const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi->plat_data->cur_ctr;
>> - const struct dw_hdmi_sym_term *sym_term = hdmi->plat_data->sym_term;
>>
>> + const struct dw_hdmi_plat_data *plat_data = hdmi->plat_data;
>> + const struct dw_hdmi_mpll_config *mpll_config = plat_data->mpll_cfg;
>> + const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data->cur_ctr;
>> + const struct dw_hdmi_sym_term *sym_term = plat_data->sym_term;
>>
>> Signed-off-by: Yakir Yang <ykk@...k-chips.com>
> I agree with Joe Perches that this commit message is not very clear.
> It should summarize what the patches is doing and why, not just be a
> copy of the change.
> e.g., "Using a local struct pointer to reduce one level of indirection
> makes the code slightly more readable."
>
> , but otherwise this is:
> Reviewed-by: Daniel Kurtz <djkurtz@...omium.org>
Okay, I will correct it now.
Thanks for your reivew :)
>> ---
>>
>> Changes in v2: None
>>
>> drivers/gpu/drm/bridge/dw_hdmi.c | 8 ++++----
>> 1 file changed, 4 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/gpu/drm/bridge/dw_hdmi.c b/drivers/gpu/drm/bridge/dw_hdmi.c
>> index 9ffc257..b9d8d8a 100644
>> --- a/drivers/gpu/drm/bridge/dw_hdmi.c
>> +++ b/drivers/gpu/drm/bridge/dw_hdmi.c
>> @@ -900,10 +900,10 @@ static int hdmi_phy_configure(struct dw_hdmi *hdmi, unsigned char prep,
>> {
>> unsigned res_idx, i;
>> u8 val, msec;
>> - const struct dw_hdmi_mpll_config *mpll_config =
>> - hdmi->plat_data->mpll_cfg;
>> - const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi->plat_data->cur_ctr;
>> - const struct dw_hdmi_sym_term *sym_term = hdmi->plat_data->sym_term;
>> + const struct dw_hdmi_plat_data *plat_data = hdmi->plat_data;
>> + const struct dw_hdmi_mpll_config *mpll_config = plat_data->mpll_cfg;
>> + const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data->cur_ctr;
>> + const struct dw_hdmi_sym_term *sym_term = plat_data->sym_term;
>>
>> if (prep)
>> return -EINVAL;
>> --
>> 2.1.2
>>
>>
>>
>> _______________________________________________
>> Linux-rockchip mailing list
>> Linux-rockchip@...ts.infradead.org
>> http://lists.infradead.org/mailman/listinfo/linux-rockchip
>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists