lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Mon, 16 Mar 2015 10:16:56 +0100
From:	Ingo Molnar <mingo@...nel.org>
To:	Jason Low <jason.low2@...com>
Cc:	Peter Zijlstra <peterz@...radead.org>,
	Linus Torvalds <torvalds@...ux-foundation.org>,
	Davidlohr Bueso <dave@...olabs.net>,
	LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] locking/mutex: Refactor mutex_spin_on_owner()


* Jason Low <jason.low2@...com> wrote:

> On Tue, 2015-03-10 at 09:11 +0100, Ingo Molnar wrote:
> > * Jason Low <jason.low2@...com> wrote:
> > 
> > > This patch applies on top of tip.
> > > 
> > > -------------------------------------------------------------------
> > > Similar to what Linus suggested for rwsem_spin_on_owner(), in
> > > mutex_spin_on_owner(), instead of having while (true) and breaking
> > > out of the spin loop on lock->owner != owner, we can have the loop
> > > directly check for while (lock->owner == owner). This improves the
> > > readability of the code.
> > > 
> > > Signed-off-by: Jason Low <jason.low2@...com>
> > > ---
> > >  kernel/locking/mutex.c |   17 +++++------------
> > >  1 files changed, 5 insertions(+), 12 deletions(-)
> > > 
> > > diff --git a/kernel/locking/mutex.c b/kernel/locking/mutex.c
> > > index 16b2d3c..1c3b7c5 100644
> > > --- a/kernel/locking/mutex.c
> > > +++ b/kernel/locking/mutex.c
> > > @@ -224,16 +224,8 @@ ww_mutex_set_context_slowpath(struct ww_mutex *lock,
> > >  static noinline
> > >  bool mutex_spin_on_owner(struct mutex *lock, struct task_struct *owner)
> > >  {
> > > -	bool ret;
> > > -
> > >  	rcu_read_lock();
> > > -	while (true) {
> > > -		/* Return success when the lock owner changed */
> > > -		if (lock->owner != owner) {
> > > -			ret = true;
> > > -			break;
> > > -		}
> > > -
> > > +	while (lock->owner == owner) {
> > >  		/*
> > >  		 * Ensure we emit the owner->on_cpu, dereference _after_
> > >  		 * checking lock->owner still matches owner, if that fails,
> > > @@ -242,16 +234,17 @@ bool mutex_spin_on_owner(struct mutex *lock, struct task_struct *owner)
> > >  		 */
> > >  		barrier();
> > >  
> > > +		/* Stop spinning when need_resched or owner is not running. */
> > >  		if (!owner->on_cpu || need_resched()) {
> > > -			ret = false;
> > > -			break;
> > > +			rcu_read_unlock();
> > > +			return false;
> > >  		}
> > >  
> > >  		cpu_relax_lowlatency();
> > >  	}
> > >  	rcu_read_unlock();
> > >  
> > > -	return ret;
> > > +	return true;
> > 
> > A nit: having multiple return statements in a function is not the 
> > cleanest approach, especially when we are holding locks.
> > 
> > It's better to add an 'out_unlock' label to before the 
> > rcu_read_unlock() and use that plus 'ret'.
> 
> Okay, I can update this patch. Should we make another similar update 
> for the rwsem then?

Yeah, I suppose so.

Thanks,

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists