[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150316092531.GI10964@mwanda>
Date: Mon, 16 Mar 2015 12:25:31 +0300
From: Dan Carpenter <dan.carpenter@...cle.com>
To: Isaac Lleida <illeida@...naliasbox.org>
Cc: willy@...a-x.org, devel@...verdev.osuosl.org,
armand.bastien@...oste.net, gregkh@...uxfoundation.org,
linux-kernel@...r.kernel.org, marius.gorski@...il.com,
domdevlin@...e.fr, kernel-janitors-owner@...r.kernel.org,
sudipm.mukherjee@...il.com
Subject: Re: [PATCH v4] staging: panel: change struct bits to a bit array
On Sun, Mar 15, 2015 at 10:03:56AM +0100, Isaac Lleida wrote:
> This path implements a bit array representing the LCD signal states instead of the old "struct bits", which used char to represent a single bit. This will reduce the memory usage.
Sudip told you to line wrap the changelog but it's still not wrapped.
Anyway, please step back and rethink the whole approach. It doesn't
save any memory when you consider how variables are stored in memory
(alignment) and it doesn't make the code more readable.
Both "bits.e" and "BIT_CHK(bits, LCD_BIT_E_MASK)" are terrible. The new
one is worse because it takes more words to tell you nothing and because
it is wrong since E is a flag not a mask.
Think about how you can make it more clear.
regards,
dan carpenter
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists