lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 16 Mar 2015 08:03:50 +0100
From:	Hans-Christian Egtvedt <egtvedt@...fundet.no>
To:	Alex Dowad <alexinbeijing@...il.com>
Cc:	linux-kernel@...t.kernel.org,
	Haavard Skinnemoen <hskinnemoen@...il.com>,
	open list <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 06/32] avr32: copy_thread(): rename 'arg' argument to
 'kthread_arg'

Around Fri 13 Mar 2015 20:04:21 +0200 or thereabout, Alex Dowad wrote:
> The 'arg' argument to copy_thread() is only ever used when forking a new
> kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency
> with do_fork() and other arch-specific implementations of copy_thread()).
> 
> Signed-off-by: Alex Dowad <alexinbeijing@...il.com>

In general
Acked-by: Hans-Christian Egtvedt <egtvedt@...fundet.no>

> ---
>  arch/avr32/kernel/process.c | 9 +++++++--
>  1 file changed, 7 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/avr32/kernel/process.c b/arch/avr32/kernel/process.c
> index 42a53e74..a255bd3 100644
> --- a/arch/avr32/kernel/process.c
> +++ b/arch/avr32/kernel/process.c
> @@ -279,20 +279,25 @@ asmlinkage void ret_from_fork(void);
>  asmlinkage void ret_from_kernel_thread(void);
>  asmlinkage void syscall_return(void);
>  
> +/*
> + * Copy architecture-specific thread state
> + */
>  int copy_thread(unsigned long clone_flags, unsigned long usp,
> -		unsigned long arg,
> +		unsigned long kthread_arg,
>  		struct task_struct *p)
>  {
>  	struct pt_regs *childregs = task_pt_regs(p);
>  
>  	if (unlikely(p->flags & PF_KTHREAD)) {
> +		/* kernel thread */

This is not needed, it is clearly stated on the line above.

>  		memset(childregs, 0, sizeof(struct pt_regs));
> -		p->thread.cpu_context.r0 = arg;
> +		p->thread.cpu_context.r0 = kthread_arg;
>  		p->thread.cpu_context.r1 = usp; /* fn */
>  		p->thread.cpu_context.r2 = (unsigned long)syscall_return;
>  		p->thread.cpu_context.pc = (unsigned long)ret_from_kernel_thread;
>  		childregs->sr = MODE_SUPERVISOR;
>  	} else {
> +		/* user thread */

Likewise, do not add obvious comments.

>  		*childregs = *current_pt_regs();
>  		if (usp)
>  			childregs->sp = usp;
-- 
Hans-Christian Egtvedt
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ