[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.DEB.2.10.1503242058300.20696@chino.kir.corp.google.com>
Date: Tue, 24 Mar 2015 21:02:13 -0700 (PDT)
From: David Rientjes <rientjes@...gle.com>
To: Naoya Horiguchi <n-horiguchi@...jp.nec.com>
cc: Andrew Morton <akpm@...ux-foundation.org>,
Andi Kleen <andi@...stfloor.org>,
Tony Luck <tony.luck@...el.com>,
Xie XiuQi <xiexiuqi@...wei.com>,
Steven Rostedt <rostedt@...dmis.org>,
Chen Gong <gong.chen@...ux.intel.com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"linux-mm@...ck.org" <linux-mm@...ck.org>
Subject: Re: [PATCH] mm/memory-failure.c: define page types for action_result()
in one place
On Thu, 19 Mar 2015, Naoya Horiguchi wrote:
> This cleanup patch moves all strings passed to action_result() into a single
> array action_page_type so that a reader can easily find which kind of action
> results are possible. And this patch also fixes the odd lines to be printed
> out, like "unknown page state page" or "free buddy, 2nd try page".
>
> Signed-off-by: Naoya Horiguchi <n-horiguchi@...jp.nec.com>
> ---
> mm/memory-failure.c | 107 +++++++++++++++++++++++++++++++++++++---------------
> 1 file changed, 76 insertions(+), 31 deletions(-)
>
> diff --git v3.19.orig/mm/memory-failure.c v3.19/mm/memory-failure.c
> index d487f8dc6d39..afb740e1c8b0 100644
> --- v3.19.orig/mm/memory-failure.c
> +++ v3.19/mm/memory-failure.c
> @@ -521,6 +521,52 @@ static const char *action_name[] = {
> [RECOVERED] = "Recovered",
> };
>
> +enum page_type {
> + KERNEL,
> + KERNEL_HIGH_ORDER,
> + SLAB,
> + DIFFERENT_COMPOUND,
> + POISONED_HUGE,
> + HUGE,
> + FREE_HUGE,
> + UNMAP_FAILED,
> + DIRTY_SWAPCACHE,
> + CLEAN_SWAPCACHE,
> + DIRTY_MLOCKED_LRU,
> + CLEAN_MLOCKED_LRU,
> + DIRTY_UNEVICTABLE_LRU,
> + CLEAN_UNEVICTABLE_LRU,
> + DIRTY_LRU,
> + CLEAN_LRU,
> + TRUNCATED_LRU,
> + BUDDY,
> + BUDDY_2ND,
> + UNKNOWN,
> +};
> +
I like the patch because of the consistency in output and think it's worth
the extra 1% .text size.
My only concern is the generic naming of the enum members.
memory-failure.c is already an offender with "enum outcome" and the naming
of its members.
Would you mind renaming these to be prefixed with "MSG_"?
These enums should be anonymous, too, nothing is referencing enum outcome
or your new enum page_type.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists