[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5518B985.5020906@oracle.com>
Date: Sun, 29 Mar 2015 20:48:37 -0600
From: David Ahern <david.ahern@...cle.com>
To: Mike Galbraith <efault@....de>
CC: peterz@...radead.org, mingo@...nel.org,
linux-kernel@...r.kernel.org
Subject: Re: [RFC PATCH] sched: Add cpu based entries to debugfs
On 3/29/15 8:32 PM, Mike Galbraith wrote:
> On Sun, 2015-03-29 at 22:13 -0400, David Ahern wrote:
>
>> diff --git a/kernel/sched/core.c b/kernel/sched/core.c
>> index 62671f53202a..b4d8d0c8260e 100644
>> --- a/kernel/sched/core.c
>> +++ b/kernel/sched/core.c
>> @@ -268,12 +268,173 @@ static const struct file_operations sched_feat_fops = {
>> .release = single_release,
>> };
>>
>> +static const char * const sd_flag_names[] = {
>> + "load-balance",
>> + "new-idle",
>> + "exec",
>> + "fork",
>> + "wake",
>> + "affine",
>> + "",
>> + "cpu-capacity",
>> + "power-domain",
>> + "share-pkg-resources",
>> + "serialize",
>> + "asym-packing",
>> + "prefer-sibling",
>> + "overlap",
>> + "numa",
>> + "",
>> +};
>
> That's wrong with the names readers will want to grep for?
I just found lower-case easier on the eyes. I could change this list to
correspond to the SD_XXXXX defines. Certainly something that more
programmatically correlates the macros (bit positions) and the names
would be better.
David
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists