lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Thu,  2 Apr 2015 15:57:00 +0300
From:	Ivan Khoronzhuk <ivan.khoronzhuk@...ballogic.com>
To:	linux-kernel@...r.kernel.org, matt.fleming@...el.com,
	jdelvare@...e.de, ard.biesheuvel@...aro.org,
	grant.likely@...aro.org, linux-api@...r.kernel.org,
	linux-doc@...r.kernel.org, mikew@...gle.com
Cc:	dmidecode-devel@...gnu.org, leif.lindholm@...aro.org,
	msalter@...hat.com, roy.franz@...aro.org,
	Ivan Khoronzhuk <ivan.khoronzhuk@...ballogic.com>
Subject: [Patch 0/3] firmware: dmi_scan: add SBMIOS entry point and DMI tables

This series adds SMBIOS entry point table and DMI table under
/sys/firmware/dmi/tables in order to use as an alternative to utilities
reading them from /dev/mem.

This is logical continuation of
"[Patch] firmware: dmi_scan: split dmisubsystem from dmi-sysfs"
https://lkml.org/lkml/2015/3/16/1070

Based on efi/next

Last changes:
	- renamed dmi_table to dmi_decode_table
	- moved tables under /sys/firmware/dmi/tables/
	- avoid "subsystem" word
	- split in separate patch correction of dmi-sysfs documentation
	- using -ENOSYS instead of -EINVAL
	- use user read only rights for table attributes
	- use "static" for attributes
	- check only dmi_available for table presents
	- don't correct dmi_walk to constantly map dmi_table
	- explicitly delete binary attributes
	- assign dmi_kobj = NULL in case of error
	- don't export dmi_kobj if CONFIG_DMI is not set
	- improve read callback for table attributes

Ivan Khoronzhuk (3):
  firmware: dmi_scan: rename dmi_table to dmi_decode_table
  firmware: dmi_scan: add SBMIOS entry and DMI tables
  Documentation: ABI: sysfs-firmware-dmi: add -entries suffix to file
    name

 ...sfs-firmware-dmi => sysfs-firmware-dmi-entries} |  2 +-
 .../ABI/testing/sysfs-firmware-dmi-tables          | 22 ++++++
 drivers/firmware/dmi-sysfs.c                       | 11 +--
 drivers/firmware/dmi_scan.c                        | 90 ++++++++++++++++++++--
 include/linux/dmi.h                                |  1 +
 5 files changed, 113 insertions(+), 13 deletions(-)
 rename Documentation/ABI/testing/{sysfs-firmware-dmi => sysfs-firmware-dmi-entries} (99%)
 create mode 100644 Documentation/ABI/testing/sysfs-firmware-dmi-tables

-- 
1.9.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ