lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 07 Apr 2015 00:30:18 +0300
From:	Stefan Strogin <s.strogin@...tner.samsung.com>
To:	Andrew Morton <akpm@...ux-foundation.org>
Cc:	Stefan Strogin <stefan.strogin@...il.com>, linux-mm@...ck.org,
	linux-kernel@...r.kernel.org,
	Dmitry Safonov <d.safonov@...tner.samsung.com>,
	Michal Nazarewicz <mina86@...a86.com>,
	Marek Szyprowski <m.szyprowski@...sung.com>,
	Joonsoo Kim <iamjoonsoo.kim@....com>,
	"Aneesh Kumar K . V" <aneesh.kumar@...ux.vnet.ibm.com>,
	Pintu Kumar <pintu.k@...sung.com>,
	Sasha Levin <sasha.levin@...cle.com>,
	Weijie Yang <weijie.yang@...sung.com>,
	Laurent Pinchart <laurent.pinchart+renesas@...asonboard.com>,
	Michal Hocko <mhocko@...e.cz>,
	Vyacheslav Tyrtov <v.tyrtov@...sung.com>,
	Aleksei Mateosian <a.mateosian@...sung.com>,
	s.strogin@...tner.samsung.com
Subject: Re: [PATCH] mm: cma: add functions to get region pages counters

Hello Andrew,

On 04/04/15 00:58, Andrew Morton wrote:
> On Fri, 03 Apr 2015 15:42:40 +0300 Stefan Strogin <stefan.strogin@...il.com> wrote:
> 
>> From: Dmitry Safonov <d.safonov@...tner.samsung.com>
>>
>> Here are two functions that provide interface to compute/get used size
>> and size of biggest free chunk in cma region. Add that information to debugfs.
>>
>> ...
>>
>> --- a/mm/cma.c
>> +++ b/mm/cma.c
>> @@ -53,6 +53,36 @@ unsigned long cma_get_size(const struct cma *cma)
>>  	return cma->count << PAGE_SHIFT;
>>  }
>>  
>> +unsigned long cma_get_used(struct cma *cma)
>> +{
>> +	unsigned long ret = 0;
>> +
>> +	mutex_lock(&cma->lock);
>> +	/* pages counter is smaller than sizeof(int) */
>> +	ret = bitmap_weight(cma->bitmap, (int)cma->count);
>> +	mutex_unlock(&cma->lock);
>> +
>> +	return ret << cma->order_per_bit;
>> +}
>> +
>> +unsigned long cma_get_maxchunk(struct cma *cma)
>> +{
>> +	unsigned long maxchunk = 0;
>> +	unsigned long start, end = 0;
>> +
>> +	mutex_lock(&cma->lock);
>> +	for (;;) {
>> +		start = find_next_zero_bit(cma->bitmap, cma->count, end);
>> +		if (start >= cma->count)
>> +			break;
>> +		end = find_next_bit(cma->bitmap, cma->count, start);
>> +		maxchunk = max(end - start, maxchunk);
>> +	}
>> +	mutex_unlock(&cma->lock);
>> +
>> +	return maxchunk << cma->order_per_bit;
>> +}
> 
> This will cause unused code to be included in cma.o when
> CONFIG_CMA_DEBUGFS=n.  Please review the below patch which moves it all
> into cma_debug.c
> 

Thank you very much for the reply and for the patches.

>> --- a/mm/cma_debug.c
>> +++ b/mm/cma_debug.c
>> @@ -33,6 +33,28 @@ static int cma_debugfs_get(void *data, u64 *val)
>>  
>>  DEFINE_SIMPLE_ATTRIBUTE(cma_debugfs_fops, cma_debugfs_get, NULL, "%llu\n");
>>  
>> +static int cma_used_get(void *data, u64 *val)
>> +{
>> +	struct cma *cma = data;
>> +
>> +	*val = cma_get_used(cma);
>> +
>> +	return 0;
>> +}
> 
> We have cma_used_get() and cma_get_used().  Confusing!  Can we think of
> better names for one or both of them?
> 

Oh. Excuse me for the bad code.
Wouldn't it be better to merge cma_get_used() and cma_get_maxchunk()
into cma_*_get() as they aren't used anywhere else?
Please see the following patch.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ