[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150409053651.GB28926@phlsvsds.ph.intel.com>
Date: Thu, 9 Apr 2015 01:36:51 -0400
From: "ira.weiny" <ira.weiny@...el.com>
To: Steve Wise <swise@...ngridcomputing.com>
Cc: "'Jason Gunthorpe'" <jgunthorpe@...idianresearch.com>,
"'Michael Wang'" <yun.wang@...fitbricks.com>,
"'Roland Dreier'" <roland@...nel.org>,
"'Sean Hefty'" <sean.hefty@...el.com>, linux-rdma@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-nfs@...r.kernel.org,
netdev@...r.kernel.org,
"'Hal Rosenstock'" <hal.rosenstock@...il.com>,
"'Tom Tucker'" <tom@...ngridcomputing.com>,
"'Hoang-Nam Nguyen'" <hnguyen@...ibm.com>,
"'Christoph Raisch'" <raisch@...ibm.com>,
"'Mike Marciniszyn'" <infinipath@...el.com>,
"'Eli Cohen'" <eli@...lanox.com>,
"'Faisal Latif'" <faisal.latif@...el.com>,
"'Upinder Malhi'" <umalhi@...co.com>,
"'Trond Myklebust'" <trond.myklebust@...marydata.com>,
"'J. Bruce Fields'" <bfields@...ldses.org>,
"'David S. Miller'" <davem@...emloft.net>,
"'PJ Waskiewicz'" <pj.waskiewicz@...idfire.com>,
"'Tatyana Nikolova'" <Tatyana.E.Nikolova@...el.com>,
"'Or Gerlitz'" <ogerlitz@...lanox.com>,
"'Jack Morgenstein'" <jackm@....mellanox.co.il>,
"'Haggai Eran'" <haggaie@...lanox.com>,
"'Ilya Nelkenbaum'" <ilyan@...lanox.com>,
"'Yann Droneaud'" <ydroneaud@...eya.com>,
"'Bart Van Assche'" <bvanassche@....org>,
"'Shachar Raindel'" <raindel@...lanox.com>,
"'Sagi Grimberg'" <sagig@...lanox.com>,
"'Devesh Sharma'" <devesh.sharma@...lex.com>,
"'Matan Barak'" <matanb@...lanox.com>,
"'Moni Shoua'" <monis@...lanox.com>,
"'Jiri Kosina'" <jkosina@...e.cz>,
"'Selvin Xavier'" <selvin.xavier@...lex.com>,
"'Mitesh Ahuja'" <mitesh.ahuja@...lex.com>,
"'Li RongQing'" <roy.qing.li@...il.com>,
"'Rasmus Villemoes'" <linux@...musvillemoes.dk>,
"'Alex Estrin'" <alex.estrin@...el.com>,
"'Doug Ledford'" <dledford@...hat.com>,
"'Eric Dumazet'" <edumazet@...gle.com>,
"'Erez Shitrit'" <erezsh@...lanox.com>,
"'Tom Gundersen'" <teg@...m.no>,
"'Chuck Lever'" <chuck.lever@...cle.com>
Subject: Re: [PATCH v2 10/17] IB/Verbs: Adopt management helpers for IB helpers
On Tue, Apr 07, 2015 at 03:16:30PM -0500, Steve Wise wrote:
>
>
> > -----Original Message-----
> > From: Jason Gunthorpe [mailto:jgunthorpe@...idianresearch.com]
> > Sent: Tuesday, April 07, 2015 3:13 PM
> > To: Michael Wang
> > Cc: Roland Dreier; Sean Hefty; linux-rdma@...r.kernel.org; linux-kernel@...r.kernel.org; linux-nfs@...r.kernel.org;
> > netdev@...r.kernel.org; Hal Rosenstock; Tom Tucker; Steve Wise; Hoang-Nam Nguyen; Christoph Raisch; Mike Marciniszyn; Eli Cohen;
> > Faisal Latif; Upinder Malhi; Trond Myklebust; J. Bruce Fields; David S. Miller; Ira Weiny; PJ Waskiewicz; Tatyana Nikolova; Or
> Gerlitz; Jack
> > Morgenstein; Haggai Eran; Ilya Nelkenbaum; Yann Droneaud; Bart Van Assche; Shachar Raindel; Sagi Grimberg; Devesh Sharma; Matan
> > Barak; Moni Shoua; Jiri Kosina; Selvin Xavier; Mitesh Ahuja; Li RongQing; Rasmus Villemoes; Alex Estrin; Doug Ledford; Eric
> Dumazet; Erez
> > Shitrit; Tom Gundersen; Chuck Lever
> > Subject: Re: [PATCH v2 10/17] IB/Verbs: Adopt management helpers for IB helpers
> >
> > On Tue, Apr 07, 2015 at 02:35:22PM +0200, Michael Wang wrote:
> > > index f704254..4e61104 100644
> > > +++ b/drivers/infiniband/core/sa_query.c
> > > @@ -540,7 +540,7 @@ int ib_init_ah_from_path(struct ib_device *device, u8 port_num,
> > > ah_attr->port_num = port_num;
> > > ah_attr->static_rate = rec->rate;
> > >
> > > - force_grh = rdma_port_get_link_layer(device, port_num) == IB_LINK_LAYER_ETHERNET;
> > > + force_grh = !rdma_transport_ib(device, port_num);
> >
> > Maybe these tests should be called cap_mandatory_grh - but I'm not
> > really sure how iWarp uses the GRH fields in the AH...
> >
>
> iWARP runs on top of TCP...this SA code is all IB-specific. The reason it was checking for ETHERNET, I think, is for RoCE. So
> this change is totally incorrect, I think, because RoCE is an IB transport, but it runs on ETHERNET.
But RoCE does not have an SA?
Looks like ib_init_ah_from_path was overloaded to handle non-standard "path
records".
It seems like the correct functionality would be to use ib_init_ah_from_path()
for true SA PathRecords and have another call iboe_init_ah() wrap
ib_init_ah_from_path() when RoCE address information is needed in the AH.
For Michaels patches I think
force_grh = rdma_device_is_iboe(...)
is the logic we need here.
Ira
>
> Steve.
>
>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists