lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <CAD3Xx4J4u=ski9qW7hVMy5pOakLS7Y_FTm7DX=n72irRTRh1cw@mail.gmail.com>
Date:	Sun, 12 Apr 2015 18:25:15 +0200
From:	Valentin Rothberg <valentinrothberg@...il.com>
To:	Peter Hurley <peter@...leysoftware.com>
Cc:	Greg KH <gregkh@...uxfoundation.org>, jslaby@...e.cz,
	linux-kernel@...r.kernel.org
Subject: Re: [PATCH] drivers/tty/nozomi.c: rename CONFIG_MAGIC

Hi Peter,

On Sun, Apr 12, 2015 at 6:16 PM, Peter Hurley <peter@...leysoftware.com> wrote:
> Hi Valentin,
>
> On 04/12/2015 10:56 AM, Valentin Rothberg wrote:
>> The CONFIG_ prefix is reserved for Kconfig options in Make and CPP
>> syntax.  CONFIG_MAGIC is a file local CPP identifier so strip the prefix
>> to apply to Kconfig's naming convention.
>>
>> Signed-off-by: Valentin Rothberg <valentinrothberg@...il.com>
>> ---
>> I found this issue with ./scripts/checkkconfigsymbols.py
>> ---
>>  drivers/tty/nozomi.c | 6 +++---
>>  1 file changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/drivers/tty/nozomi.c b/drivers/tty/nozomi.c
>> index 74885af8c7bd..4a4775e81963 100644
>> --- a/drivers/tty/nozomi.c
>> +++ b/drivers/tty/nozomi.c
>> @@ -140,7 +140,7 @@ static int debug;
>>  #define R_FCR                0x0000  /* Flow Control Register */
>>  #define R_IER                0x0004  /* Interrupt Enable Register */
>>
>> -#define CONFIG_MAGIC 0xEFEFFEFE
>> +#define MAGIC                        0xEFEFFEFE
>            ^^^^^
> This is too general for a preprocessor symbol; how about
> NOZOMI_CONFIG_MAGIC?

Okay, sounds much better than ``MAGIC''.  I will send a second version
of this patch.

Kind regards,
 Valentin

> Regards,
> Peter Hurley
>
>>  #define TOGGLE_VALID 0x0000
>>
>>  /* Definition of interrupt tokens */
>> @@ -660,9 +660,9 @@ static int nozomi_read_config_table(struct nozomi *dc)
>>       read_mem32((u32 *) &dc->config_table, dc->base_addr + 0,
>>                                               sizeof(struct config_table));
>>
>> -     if (dc->config_table.signature != CONFIG_MAGIC) {
>> +     if (dc->config_table.signature != MAGIC) {
>>               dev_err(&dc->pdev->dev, "ConfigTable Bad! 0x%08X != 0x%08X\n",
>> -                     dc->config_table.signature, CONFIG_MAGIC);
>> +                     dc->config_table.signature, MAGIC);
>>               return 0;
>>       }
>>
>>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ