[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <096df9441c4492ab31851eba63fee4408872d06f.1429121009.git.rgb@redhat.com>
Date: Wed, 15 Apr 2015 14:08:25 -0400
From: Richard Guy Briggs <rgb@...hat.com>
To: linux-security-module@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-audit@...hat.com
Cc: Richard Guy Briggs <rgb@...hat.com>, sgrubb@...hat.com,
eparis@...isplace.org, pmoore@...hat.com, jmorris@...ei.org
Subject: [PATCH] lsm: rename duplicate labels in LSM_AUDIT_DATA_TASK audit message type
The LSM_AUDIT_DATA_TASK pid= and comm= labels are duplicates of those at the
start of this function with different values. Rename them to their object
counterparts opid= and ocomm= to disambiguate.
Signed-off-by: Richard Guy Briggs <rgb@...hat.com>
---
security/lsm_audit.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/security/lsm_audit.c b/security/lsm_audit.c
index b526ddc..3323144 100644
--- a/security/lsm_audit.c
+++ b/security/lsm_audit.c
@@ -282,7 +282,7 @@ static void dump_common_audit_data(struct audit_buffer *ab,
pid_t pid = task_pid_nr(tsk);
if (pid) {
char comm[sizeof(tsk->comm)];
- audit_log_format(ab, " pid=%d comm=", pid);
+ audit_log_format(ab, " opid=%d ocomm=", pid);
audit_log_untrustedstring(ab,
memcpy(comm, tsk->comm, sizeof(comm)));
}
--
1.7.1
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists