[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <552FC441.5070500@dev.mellanox.co.il>
Date: Thu, 16 Apr 2015 10:16:33 -0400
From: Hal Rosenstock <hal@....mellanox.co.il>
To: Or Gerlitz <gerlitz.or@...il.com>
CC: Michael Wang <yun.wang@...fitbricks.com>,
"Hefty, Sean" <sean.hefty@...el.com>,
Roland Dreier <roland@...nel.org>,
Hal Rosenstock <hal.rosenstock@...il.com>,
"linux-rdma@...r.kernel.org" <linux-rdma@...r.kernel.org>,
Linux Kernel <linux-kernel@...r.kernel.org>,
Tom Tucker <tom@...ngridcomputing.com>,
Steve Wise <swise@...ngridcomputing.com>,
Hoang-Nam Nguyen <hnguyen@...ibm.com>,
Christoph Raisch <raisch@...ibm.com>,
Mike Marciniszyn <infinipath@...el.com>,
Eli Cohen <eli@...lanox.com>,
Faisal Latif <faisal.latif@...el.com>,
Jack Morgenstein <jackm@....mellanox.co.il>,
Or Gerlitz <ogerlitz@...lanox.com>,
Haggai Eran <haggaie@...lanox.com>,
Ira Weiny <ira.weiny@...el.com>, Tom Talpey <tom@...pey.com>,
Jason Gunthorpe <jgunthorpe@...idianresearch.com>,
Doug Ledford <dledford@...hat.com>
Subject: Re: [PATCH v3 25/28] IB/Verbs: Use management helper cap_af_ib()
On 4/16/2015 9:57 AM, Or Gerlitz wrote:
> On Mon, Apr 13, 2015 at 3:35 PM, Michael Wang <yun.wang@...fitbricks.com> wrote:
>>
>> Introduce helper cap_af_ib() to help us check if the port of an
>> IB device support Native Infiniband Address.
>>
>> Cc: Steve Wise <swise@...ngridcomputing.com>
>> Cc: Tom Talpey <tom@...pey.com>
>> Cc: Jason Gunthorpe <jgunthorpe@...idianresearch.com>
>> Cc: Doug Ledford <dledford@...hat.com>
>> Cc: Ira Weiny <ira.weiny@...el.com>
>> Cc: Sean Hefty <sean.hefty@...el.com>
>> Signed-off-by: Michael Wang <yun.wang@...fitbricks.com>
>> ---
>> drivers/infiniband/core/cma.c | 2 +-
>> include/rdma/ib_verbs.h | 15 +++++++++++++++
>> 2 files changed, 16 insertions(+), 1 deletion(-)
>>
>> diff --git a/drivers/infiniband/core/cma.c b/drivers/infiniband/core/cma.c
>> index 65e41f4..7f5815d 100644
>> --- a/drivers/infiniband/core/cma.c
>> +++ b/drivers/infiniband/core/cma.c
>> @@ -470,7 +470,7 @@ static int cma_resolve_ib_dev(struct rdma_id_private *id_priv)
>>
>> list_for_each_entry(cur_dev, &dev_list, list) {
>> for (p = 1; p <= cur_dev->device->phys_port_cnt; ++p) {
>> - if (!rdma_ib_or_iboe(cur_dev->device, p))
>> + if (!cap_af_ib(cur_dev->device, p))
>> continue;
>>
>> if (ib_find_cached_pkey(cur_dev->device, p, pkey, &index))
>> diff --git a/include/rdma/ib_verbs.h b/include/rdma/ib_verbs.h
>> index 29ddd14..dfe33f3 100644
>> --- a/include/rdma/ib_verbs.h
>> +++ b/include/rdma/ib_verbs.h
>> @@ -1879,6 +1879,21 @@ static inline int cap_ipoib(struct ib_device *device, u8 port_num)
>> }
>>
>> /**
>> + * cap_af_ib - Check if the port of device has the capability
>> + * Native Infiniband Address.
>> + *
>> + * @device: Device to be checked
>> + * @port_num: Port number of the device
>> + *
>> + * Return 0 when port of the device don't support
>> + * Native Infiniband Address.
>> + */
>> +static inline int cap_af_ib(struct ib_device *device, u8 port_num)
>> +{
>> + return rdma_ib_or_iboe(device, port_num);
>> +}
>
> Sean, can you please put a precise writeup what does it take to
> support AF_IB... I am a bit
> confused here and wasn't sure if this can be supported with RoCE.
I think this means IB GID addressing is checked (Native Infiniband
Address) and not AF_IB (which is socket address/protocol family like
INET and INET6).
I think this naming is confusing and maybe cap_ib_gid is better ?
-- Hal
> --
> To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists