lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 20 Apr 2015 13:19:44 +0300
From:	Ivan Khoronzhuk <ivan.khoronzhuk@...ballogic.com>
To:	linux-kernel@...r.kernel.org, matt.fleming@...el.com,
	jdelvare@...e.de, ard.biesheuvel@...aro.org,
	grant.likely@...aro.org, linux-api@...r.kernel.org,
	linux-doc@...r.kernel.org, mikew@...gle.com
Cc:	dmidecode-devel@...gnu.org, leif.lindholm@...aro.org,
	msalter@...hat.com, roy.franz@...aro.org,
	Ivan Khoronzhuk <ivan.khoronzhuk@...ballogic.com>
Subject: [Patch v2 0/3] firmware: dmi_scan: add SBMIOS entry point and DMI tables

This series adds SMBIOS entry point table and DMI table under
/sys/firmware/dmi/tables in order to use as an alternative to utilities
reading them from /dev/mem.

Based on linux next
+ 2 patches that have not been sent by Jean Dalvere yet. They can be changed,
but, anyway, the series should be based on smth and it's desirable w/o
conflicts. The patches can be obtained with links:

http://jdelvare.nerim.net/devel/linux-3/jdelvare-dmi/firmware-dmi-03-simplify-displayed-version.patch
http://jdelvare.nerim.net/devel/linux-3/jdelvare-dmi/firmware-dmi-04-fix-product-uuid.patch

Link on V1:
https://lkml.org/lkml/2015/4/2/297

Changes since V1
	- correct error path in dmi-sysfs
	- don't use globally dmi_table var
	- use "DMI" in attribute name
	- correct error path in dmi_init
	- leave dmi_kobj even in case of error
	- include linux/kobject.h in header

Ivan Khoronzhuk (3):
  firmware: dmi_scan: rename dmi_table to dmi_decode_table
  firmware: dmi_scan: add SBMIOS entry and DMI tables
  Documentation: ABI: sysfs-firmware-dmi: add -entries suffix to file
    name

 ...sfs-firmware-dmi => sysfs-firmware-dmi-entries} |  2 +-
 .../ABI/testing/sysfs-firmware-dmi-tables          | 22 ++++++
 drivers/firmware/dmi-sysfs.c                       | 17 ++--
 drivers/firmware/dmi_scan.c                        | 92 ++++++++++++++++++++--
 include/linux/dmi.h                                |  2 +
 5 files changed, 120 insertions(+), 15 deletions(-)
 rename Documentation/ABI/testing/{sysfs-firmware-dmi => sysfs-firmware-dmi-entries} (99%)
 create mode 100644 Documentation/ABI/testing/sysfs-firmware-dmi-tables

-- 
1.9.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ