lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 29 Apr 2015 19:58:25 +0900
From:	Krzysztof Kozlowski <k.kozlowski.k@...il.com>
To:	Chanwoo Choi <cw00.choi@...sung.com>,
	MyungJoo Ham <myungjoo.ham@...sung.com>,
	Dmitry Torokhov <dmitry.torokhov@...il.com>,
	Samuel Ortiz <sameo@...ux.intel.com>,
	Lee Jones <lee.jones@...aro.org>,
	Sebastian Reichel <sre@...nel.org>,
	Dmitry Eremin-Solenikov <dbaryshkov@...il.com>,
	David Woodhouse <dwmw2@...radead.org>,
	Liam Girdwood <lgirdwood@...il.com>,
	Mark Brown <broonie@...nel.org>, linux-kernel@...r.kernel.org,
	linux-input@...r.kernel.org, linux-pm@...r.kernel.org
Cc:	Krzysztof Kozlowski <k.kozlowski.k@...il.com>
Subject: [PATCH 00/10] regulator/power/mfd/input/extcon: Merge max77843 into max77693

Hi,


The patchset merges max77843 regulator driver into max77693.
I am asking for review and acks from multiple subsystems.


Rationale
=========
The recently added max77843 regulator driver is very similar to
its older brother: the max77693. Both devices provide two safeouts
and a charger.

The main difference is in charger's output capabilities and related
registry values.

With some code additions the max77693 regulator driver can support both
chipsets. This reduces overall code duplication and is a first step
toward integrating other drivers for these devices.


Patchset description
====================
Patches 1-3 do various cleanup.
Patch 4 prepare max77694 regulator driver for supporting different
devices.
Patch 5 switch max77693 drivers to common state container.
Patch 6 updates max77843 drivers to common state container.
Patches 7-8 do final cleanup before merging.
Patches 9-10 do the merge of max77843 regulator into max77693.


Dependencies
============
The patchset is rebased on current regulator tree:
v4.1-rc1-8-ge2a4e9538fe6. It touches all currently merged max77843
drivers: extcon, mfd, input and regulator (charger driver was not yet
merged).


Best regards,
Krzysztof


Krzysztof Kozlowski (10):
  mfd/extcon: max77693: Remove unused extern declarations and
    max77693_dev members
  mfd: max77693: Store I2C device type as enum and add default unknown
  regulator: max77693: Use core code for charger's is_enabled
  regulator: max77693: Support different register configurations
  max77693: Move state container to common header
  max77843: Switch to common max77693 state container
  mfd/extcon: max77693: Rename defines to allow inclusion with max77843
  mfd/extcon: max77843: Rename defines to allow inclusion with max77693
  regulator: max77693: Add support for MAX77843 device
  regulator: Remove the max77843 driver

 drivers/extcon/extcon-max77693.c     |  83 +++++++-------
 drivers/extcon/extcon-max77843.c     |  76 ++++++++-----
 drivers/input/misc/max77693-haptic.c |   1 +
 drivers/input/misc/max77843-haptic.c |   3 +-
 drivers/mfd/max77693.c               |  31 ++---
 drivers/mfd/max77843.c               |  20 ++--
 drivers/power/max77693_charger.c     |   1 +
 drivers/regulator/Kconfig            |  16 +--
 drivers/regulator/Makefile           |   1 -
 drivers/regulator/max77693.c         | 174 ++++++++++++++++++++++------
 drivers/regulator/max77843.c         | 215 -----------------------------------
 include/linux/mfd/max77693-common.h  |  49 ++++++++
 include/linux/mfd/max77693-private.h | 134 +++++++++-------------
 include/linux/mfd/max77843-private.h | 174 +++++++++++++---------------
 14 files changed, 443 insertions(+), 535 deletions(-)
 delete mode 100644 drivers/regulator/max77843.c
 create mode 100644 include/linux/mfd/max77693-common.h

-- 
2.1.4

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ