[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <tip-ce2f5fe46303d1e1a2ba453753a7e8200d32182c@git.kernel.org>
Date: Fri, 8 May 2015 06:21:41 -0700
From: tip-bot for Nicholas Mc Guire <tipbot@...or.com>
To: linux-tip-commits@...r.kernel.org
Cc: hpa@...or.com, tglx@...utronix.de, hofrat@...dl.org,
akpm@...ux-foundation.org, mingo@...nel.org, peterz@...radead.org,
torvalds@...ux-foundation.org, linux-kernel@...r.kernel.org,
bp@...en8.de
Subject: [tip:sched/core] sched/core: Remove unnecessary down/
up conversion
Commit-ID: ce2f5fe46303d1e1a2ba453753a7e8200d32182c
Gitweb: http://git.kernel.org/tip/ce2f5fe46303d1e1a2ba453753a7e8200d32182c
Author: Nicholas Mc Guire <hofrat@...dl.org>
AuthorDate: Sun, 3 May 2015 10:51:56 +0200
Committer: Ingo Molnar <mingo@...nel.org>
CommitDate: Fri, 8 May 2015 12:10:07 +0200
sched/core: Remove unnecessary down/up conversion
'rt_period_us' is automatically type converted from u64 to long and then cast
back to u64 - this down/up conversion is unnecessary and can be removed to
improve readability.
This will also help us not truncate 'rt_period_us' to 32 bits on 32-bit kernels,
should we ever have so large values. (unlikely, not the least due to procfs.)
Signed-off-by: Nicholas Mc Guire <hofrat@...dl.org>
Signed-off-by: Peter Zijlstra (Intel) <peterz@...radead.org>
Cc: Andrew Morton <akpm@...ux-foundation.org>
Cc: Borislav Petkov <bp@...en8.de>
Cc: H. Peter Anvin <hpa@...or.com>
Cc: Linus Torvalds <torvalds@...ux-foundation.org>
Cc: Peter Zijlstra <peterz@...radead.org>
Cc: Thomas Gleixner <tglx@...utronix.de>
Link: http://lkml.kernel.org/r/1430643116-24049-1-git-send-email-hofrat@osadl.org
Signed-off-by: Ingo Molnar <mingo@...nel.org>
---
kernel/sched/core.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/kernel/sched/core.c b/kernel/sched/core.c
index 527fc28..46a5d6f 100644
--- a/kernel/sched/core.c
+++ b/kernel/sched/core.c
@@ -7738,11 +7738,11 @@ static long sched_group_rt_runtime(struct task_group *tg)
return rt_runtime_us;
}
-static int sched_group_set_rt_period(struct task_group *tg, long rt_period_us)
+static int sched_group_set_rt_period(struct task_group *tg, u64 rt_period_us)
{
u64 rt_runtime, rt_period;
- rt_period = (u64)rt_period_us * NSEC_PER_USEC;
+ rt_period = rt_period_us * NSEC_PER_USEC;
rt_runtime = tg->rt_bandwidth.rt_runtime;
return tg_set_rt_bandwidth(tg, rt_period, rt_runtime);
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists