[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <CAOi1vP9k4UUJ_Dus6xpN+7GGEA=X4SbaD3WxHy5cVE9S8WtmYA@mail.gmail.com>
Date: Mon, 1 Jun 2015 18:03:18 +0300
From: Ilya Dryomov <idryomov@...il.com>
To: Geliang Tang <geliangtang@....com>
Cc: "Yan, Zheng" <zyan@...hat.com>, Sage Weil <sage@...hat.com>,
"David S. Miller" <davem@...emloft.net>,
Ceph Development <ceph-devel@...r.kernel.org>,
netdev <netdev@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] libceph: use kvfree() in ceph_put_page_vector()
On Mon, Jun 1, 2015 at 5:36 PM, Geliang Tang <geliangtang@....com> wrote:
> Use kvfree() instead of open-coding it.
>
> Signed-off-by: Geliang Tang <geliangtang@....com>
> ---
> net/ceph/pagevec.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/net/ceph/pagevec.c b/net/ceph/pagevec.c
> index 096d914..d4f5f22 100644
> --- a/net/ceph/pagevec.c
> +++ b/net/ceph/pagevec.c
> @@ -51,10 +51,7 @@ void ceph_put_page_vector(struct page **pages, int num_pages, bool dirty)
> set_page_dirty_lock(pages[i]);
> put_page(pages[i]);
> }
> - if (is_vmalloc_addr(pages))
> - vfree(pages);
> - else
> - kfree(pages);
> + kvfree(pages);
> }
> EXPORT_SYMBOL(ceph_put_page_vector);
Already fixed in testing, wasn't pushed to linux-next though, sorry!
Thanks,
Ilya
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists