[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150604100741.GG3644@twins.programming.kicks-ass.net>
Date: Thu, 4 Jun 2015 12:07:41 +0200
From: Peter Zijlstra <peterz@...radead.org>
To: Ingo Molnar <mingo@...nel.org>
Cc: Thomas Gleixner <tglx@...utronix.de>, umgwanakikbuti@...il.com,
mingo@...e.hu, ktkhai@...allels.com, rostedt@...dmis.org,
juri.lelli@...il.com, pang.xunlei@...aro.org, oleg@...hat.com,
wanpeng.li@...ux.intel.com, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 8/9] hrtimer: Allow hrtimer::function() to free the timer
On Thu, Jun 04, 2015 at 07:59:30AM +0200, Ingo Molnar wrote:
> > --- a/include/linux/hrtimer.h
> > +++ b/include/linux/hrtimer.h
> > @@ -123,8 +123,10 @@ struct hrtimer_sleeper {
> >
> > #ifdef CONFIG_64BIT
> > # define HRTIMER_CLOCK_BASE_ALIGN 64
> > +# define __timer_base_running(timer) timer->base->running
> > #else
> > # define HRTIMER_CLOCK_BASE_ALIGN 32
> > +# define __timer_base_running(timer) timer->base->cpu_base->running
> > #endif
>
> Please put it into the cpu_base on 64-bit as well: the base pointer is available
> already on 64-bit so there should be no measurable performance difference, and
> readability is a primary concern with all this code.
That's an extra pointer chase for no reason :-(
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists