lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Sat, 6 Jun 2015 20:49:46 +0300
From:	Oded Gabbay <oded.gabbay@...il.com>
To:	Valentin Rothberg <valentinrothberg@...il.com>
Cc:	Maling list - DRI developers <dri-devel@...ts.freedesktop.org>,
	"Linux-Kernel@...r. Kernel. Org" <linux-kernel@...r.kernel.org>,
	deathsimple@...afone.de, hengelein Stefan <stefan.hengelein@....de>
Subject: Re: [PATCH] drm/amdkfd: avoid CONFIG_ prefix for non-Kconfig symbols

On Fri, Jun 5, 2015 at 11:27 AM, Valentin Rothberg
<valentinrothberg@...il.com> wrote:
> The CONFIG_ prefix is reserved for Kconfig options in Make and CPP
> syntax.  Various static analysis tools rely on this naming convention
> and check if CONFIG_ prefixed symbols are defined Kconfig.  Hence add
> yet another prefix AMD_ to CONFIG_REG_{BASE,END,SISE} to apply to this
> convention and make static analysis tools happy.
>
> Signed-off-by: Valentin Rothberg <valentinrothberg@...il.com>
> ---
>  drivers/gpu/drm/amd/amdkfd/kfd_dbgdev.c | 10 +++++-----
>  drivers/gpu/drm/amd/amdkfd/kfd_dbgdev.h |  6 +++---
>  2 files changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_dbgdev.c b/drivers/gpu/drm/amd/amdkfd/kfd_dbgdev.c
> index 96153f28d73f..c34c393e9aea 100644
> --- a/drivers/gpu/drm/amd/amdkfd/kfd_dbgdev.c
> +++ b/drivers/gpu/drm/amd/amdkfd/kfd_dbgdev.c
> @@ -445,7 +445,7 @@ static int dbgdev_address_watch_diq(struct kfd_dbgdev *dbgdev,
>                 aw_reg_add_dword /= sizeof(uint32_t);
>
>                 packets_vec[0].bitfields2.reg_offset =
> -                                       aw_reg_add_dword - CONFIG_REG_BASE;
> +                                       aw_reg_add_dword - AMD_CONFIG_REG_BASE;
>
>                 packets_vec[0].reg_data[0] = cntl.u32All;
>
> @@ -458,7 +458,7 @@ static int dbgdev_address_watch_diq(struct kfd_dbgdev *dbgdev,
>                 aw_reg_add_dword /= sizeof(uint32_t);
>
>                 packets_vec[1].bitfields2.reg_offset =
> -                                       aw_reg_add_dword - CONFIG_REG_BASE;
> +                                       aw_reg_add_dword - AMD_CONFIG_REG_BASE;
>                 packets_vec[1].reg_data[0] = addrHi.u32All;
>
>                 aw_reg_add_dword =
> @@ -470,7 +470,7 @@ static int dbgdev_address_watch_diq(struct kfd_dbgdev *dbgdev,
>                 aw_reg_add_dword /= sizeof(uint32_t);
>
>                 packets_vec[2].bitfields2.reg_offset =
> -                               aw_reg_add_dword - CONFIG_REG_BASE;
> +                               aw_reg_add_dword - AMD_CONFIG_REG_BASE;
>                 packets_vec[2].reg_data[0] = addrLo.u32All;
>
>                 /* enable watch flag if address is not zero*/
> @@ -488,7 +488,7 @@ static int dbgdev_address_watch_diq(struct kfd_dbgdev *dbgdev,
>                 aw_reg_add_dword /= sizeof(uint32_t);
>
>                 packets_vec[3].bitfields2.reg_offset =
> -                                       aw_reg_add_dword - CONFIG_REG_BASE;
> +                                       aw_reg_add_dword - AMD_CONFIG_REG_BASE;
>                 packets_vec[3].reg_data[0] = cntl.u32All;
>
>                 status = dbgdev_diq_submit_ib(
> @@ -690,7 +690,7 @@ static int dbgdev_wave_control_diq(struct kfd_dbgdev *dbgdev,
>         packets_vec[1].header.opcode = IT_SET_CONFIG_REG;
>         packets_vec[1].header.type = PM4_TYPE_3;
>         packets_vec[1].bitfields2.reg_offset = SQ_CMD / (sizeof(uint32_t)) -
> -                                               CONFIG_REG_BASE;
> +                                               AMD_CONFIG_REG_BASE;
>
>         packets_vec[1].bitfields2.vmid_shift = SQ_CMD_VMID_OFFSET;
>         packets_vec[1].bitfields2.insert_vmid = 1;
> diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_dbgdev.h b/drivers/gpu/drm/amd/amdkfd/kfd_dbgdev.h
> index 4b0dd5aa5306..03424c20920c 100644
> --- a/drivers/gpu/drm/amd/amdkfd/kfd_dbgdev.h
> +++ b/drivers/gpu/drm/amd/amdkfd/kfd_dbgdev.h
> @@ -48,9 +48,9 @@ enum {
>
>  /* CONFIG reg space definition */
>  enum {
> -       CONFIG_REG_BASE = 0x2000,       /* in dwords */
> -       CONFIG_REG_END = 0x2B00,
> -       CONFIG_REG_SIZE = CONFIG_REG_END - CONFIG_REG_BASE
> +       AMD_CONFIG_REG_BASE = 0x2000,   /* in dwords */
> +       AMD_CONFIG_REG_END = 0x2B00,
> +       AMD_CONFIG_REG_SIZE = AMD_CONFIG_REG_END - AMD_CONFIG_REG_BASE
>  };
>
>  /* SH reg space definition */
> --
> 2.4.2
>

Thanks!
Applied to my -next-fixes tree

Oded
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ