lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sat, 6 Jun 2015 13:22:30 +0900
From:	Greg KH <gregkh@...uxfoundation.org>
To:	Wei Yang <weiyang@...ux.vnet.ibm.com>
Cc:	linux-kernel@...r.kernel.org
Subject: Re: [PATCH] kobject: avoid unnecessary assignment of kobj->parent

On Thu, Jun 04, 2015 at 10:13:50AM +0800, Wei Yang wrote:
> kobj->parent is changed only when it is NULL originally.
> 
> This patch moves the assignment in the "if" to avoid unnecessary assignment.
> 
> Signed-off-by: Wei Yang <weiyang@...ux.vnet.ibm.com>
> ---
>  lib/kobject.c |    3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/lib/kobject.c b/lib/kobject.c
> index 03d4ab3..37b10bb 100644
> --- a/lib/kobject.c
> +++ b/lib/kobject.c
> @@ -216,9 +216,8 @@ static int kobject_add_internal(struct kobject *kobj)
>  	/* join kset if set, use it as parent if we do not already have one */
>  	if (kobj->kset) {
>  		if (!parent)
> -			parent = kobject_get(&kobj->kset->kobj);
> +			parent = kobj->parent = kobject_get(&kobj->kset->kobj);
>  		kobj_kset_join(kobj);
> -		kobj->parent = parent;

What is this "fixing"?  I hate multiple assignments on the same line,
it makes it harder to read and understand.

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ