lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 8 Jun 2015 17:18:56 -0400
From:	Brian Gerst <brgerst@...il.com>
To:	Ingo Molnar <mingo@...nel.org>
Cc:	"H. Peter Anvin" <hpa@...or.com>,
	Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
	Denys Vlasenko <dvlasenk@...hat.com>,
	Peter Zijlstra <peterz@...radead.org>,
	Borislav Petkov <bp@...en8.de>,
	Andy Lutomirski <luto@...capital.net>,
	Linus Torvalds <torvalds@...ux-foundation.org>,
	Thomas Gleixner <tglx@...utronix.de>,
	linux-tip-commits@...r.kernel.org
Subject: Re: [PATCH] x86/asm/entry: (Re-)rename __NR_entry_INT80_compat_max to __NR_syscall_compat_max

On Mon, Jun 8, 2015 at 3:25 PM, Ingo Molnar <mingo@...nel.org> wrote:
>
> * Brian Gerst <brgerst@...il.com> wrote:
>
>> > diff --git a/arch/x86/entry/syscall_32.c b/arch/x86/entry/syscall_32.c
>> > index 3777189..e398d03 100644
>> > --- a/arch/x86/entry/syscall_32.c
>> > +++ b/arch/x86/entry/syscall_32.c
>> > @@ -10,7 +10,7 @@
>> >  #else
>> >  #define SYM(sym, compat) sym
>> >  #define ia32_sys_call_table sys_call_table
>> > -#define __NR_ia32_syscall_max __NR_syscall_max
>> > +#define __NR_entry_INT80_compat_max __NR_syscall_max
>> >  #endif
>>
>> This change doesn't look intended.  __NR_ia32_syscall_max is used by
>> all compat entry points, not just INT80,
>
> Indeed!
>
> How about the patch below?
>
> Thanks,
>
>         Ingo
>
> ================>
> From 42b9d9a463bfb7252ede4eac24e50a4f013c6717 Mon Sep 17 00:00:00 2001
> From: Ingo Molnar <mingo@...nel.org>
> Date: Mon, 8 Jun 2015 21:20:26 +0200
> Subject: [PATCH] x86/asm/entry: (Re-)rename __NR_entry_INT80_compat_max to __NR_syscall_compat_max
>
> Brian Gerst noticed that I did a weird rename in the following commit:
>
>    b2502b418e63 ("x86/asm/entry: Untangle 'system_call' into two entry points: entry_SYSCALL_64 and entry_INT80_32")
>
> which renamed __NR_ia32_syscall_max to __NR_entry_INT80_compat_max.
>
> Now the original name was a misnomer, but the new one is a misnomer as well,
> as all compat syscall ABIs (such as x32) share the system call table, not just
> INT80 based ones.

Not quite true.  X32 is really an extension of the 64-bit ABI to
support the ILP32 data model.  It uses the 64-bit SYSCALL entry point
and table, but with different syscall numbers for the syscalls that
need 32-bit pointer handling in data structures.

So, __NR_syscall_compat_max is only for the 32-bit ABI compat syscall
entries (int80, sysenter, and syscall from 32-bit mode), and not X32.

--
Brian Gerst
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ