lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Mon, 15 Jun 2015 09:27:20 +0100
From:	Mel Gorman <mgorman@...e.de>
To:	Hillf Danton <hillf.zj@...baba-inc.com>
Cc:	linux-mm@...ck.org, linux-kernel <linux-kernel@...r.kernel.org>,
	Rik van Riel <riel@...hat.com>,
	Johannes Weiner <hannes@...xchg.org>,
	Michal Hocko <mhocko@...e.cz>
Subject: Re: [PATCH 07/25] mm, vmscan: Make kswapd think of reclaim in terms
 of nodes

On Fri, Jun 12, 2015 at 03:05:00PM +0800, Hillf Danton wrote:
> > -	/* Reclaim above the high watermark. */
> > -	sc->nr_to_reclaim = max(SWAP_CLUSTER_MAX, high_wmark_pages(zone));
> > +	/* Aim to reclaim above all the zone high watermarks */
> > +	for (z = 0; z <= end_zone; z++) {
> > +		zone = pgdat->node_zones + end_zone;
> s/end_zone/z/ ?

Ouch, thanks!

With this bug, kswapd would reclaim based on a multiple of the highest
zone. Whether that was under or over reclaim would depend on the size of
that zone relative to lower zones.

> > +		nr_to_reclaim += high_wmark_pages(zone);
> > 
> [...]
> > @@ -3280,13 +3177,26 @@ static unsigned long balance_pgdat(pg_data_t *pgdat, int order,
> >  			compact_pgdat(pgdat, order);
> > 
> >  		/*
> > +		 * Stop reclaiming if any eligible zone is balanced and clear
> > +		 * node writeback or congested.
> > +		 */
> > +		for (i = 0; i <= *classzone_idx; i++) {
> > +			zone = pgdat->node_zones + i;
> > +
> > +			if (zone_balanced(zone, sc.order, 0, *classzone_idx)) {
> > +				clear_bit(PGDAT_CONGESTED, &pgdat->flags);
> > +				clear_bit(PGDAT_DIRTY, &pgdat->flags);
> > +				break;
> s/break/goto out/ ?

Yes. It'd actually be ok because it'll detect the same condition and
exit in the next outer loop but goto out is better.


-- 
Mel Gorman
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ