lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 16 Jun 2015 18:24:07 -0400
From:	Stephane Viau <sviau@...eaurora.org>
To:	dri-devel@...ts.freedesktop.org
Cc:	linux-arm-msm@...r.kernel.org, linux-kernel@...r.kernel.org,
	robdclark@...il.com, Stephane Viau <sviau@...eaurora.org>
Subject: [RFC 0/2] drm/msm: HDMI PHY rework for MSM8x94 support

The RFC concerns a code restructuring of the HDMI module, which mainly has two
purposes:

1. architectural 
HDMI registers are divided in two parts: HDMI core and HDMI PHY. The HDMI Core
registers are common to all chipsets sharing the MDP version (MDP5 here). On
the other hand, HDMI PHY registers depend on the interface and process (28nm,
20nm, ...) being used for the same chipsets. Some chipsets (eg: msm8x94) don't
require us to access HDMI PHY registers.
>From a software architecture point of view, it would make sense that all HDMI
PHY registers should only be accessed by (PHY) hdmi_phy_*.c files, while all 
HDMI Core registers are read/written by the (core) hdmi.c and hdmi_connector.c
files.

2. readability 
Once we add msm8x94, which does not program HDMI PHY registers, it will be
easier to handle the HDMI core register programming because a hdmi_phy_*.c
file won't be created for this chipset. Instead of creating such a stub file
or some kind of workaround, it only makes sense to bring the HDMI core register 
programming where it is supposed to be.

To summarize, this re-structuring is to improve the code architecture,
facilitate the introduction of msm8x94 support and won't change the current
functionality.

Stephane Viau (2):
  [RFC] drm/msm/hdmi: remove ->reset() from HDMI PHY
  drm/msm: Add support for msm8x94

 drivers/gpu/drm/msm/hdmi/hdmi.c           | 30 ++++++----
 drivers/gpu/drm/msm/hdmi/hdmi.h           |  1 -
 drivers/gpu/drm/msm/hdmi/hdmi_bridge.c    |  8 ++-
 drivers/gpu/drm/msm/hdmi/hdmi_connector.c | 94 +++++++++++++++++++++++++------
 drivers/gpu/drm/msm/hdmi/hdmi_phy_8960.c  | 52 -----------------
 drivers/gpu/drm/msm/hdmi/hdmi_phy_8x60.c  | 32 -----------
 drivers/gpu/drm/msm/hdmi/hdmi_phy_8x74.c  | 57 -------------------
 drivers/gpu/drm/msm/mdp/mdp5/mdp5_cfg.c   | 73 +++++++++++++++++++++++-
 drivers/gpu/drm/msm/mdp/mdp5/mdp5_kms.c   |  8 ++-
 9 files changed, 179 insertions(+), 176 deletions(-)

-- 
Qualcomm Innovation Center, Inc.

The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum, a Linux Foundation Collaborative Project

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ