[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150617152756.GA3913@linux.vnet.ibm.com>
Date: Wed, 17 Jun 2015 08:27:56 -0700
From: "Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>
To: Ingo Molnar <mingo@...nel.org>
Cc: Andy Lutomirski <luto@...nel.org>, x86@...nel.org,
linux-kernel@...r.kernel.org,
Frédéric Weisbecker <fweisbec@...il.com>,
Rik van Riel <riel@...hat.com>,
Oleg Nesterov <oleg@...hat.com>,
Denys Vlasenko <vda.linux@...glemail.com>,
Borislav Petkov <bp@...en8.de>,
Kees Cook <keescook@...omium.org>,
Brian Gerst <brgerst@...il.com>
Subject: Re: [RFC/INCOMPLETE 01/13] context_tracking: Add
context_tracking_assert_state
On Wed, Jun 17, 2015 at 11:41:14AM +0200, Ingo Molnar wrote:
>
> * Andy Lutomirski <luto@...nel.org> wrote:
>
> > This will let us sprinkle sanity checks around the kernel without
> > making too much of a mess.
> >
> > Signed-off-by: Andy Lutomirski <luto@...nel.org>
> > ---
> > include/linux/context_tracking.h | 8 ++++++++
> > 1 file changed, 8 insertions(+)
> >
> > diff --git a/include/linux/context_tracking.h b/include/linux/context_tracking.h
> > index 2821838256b4..0fbea4b152e1 100644
> > --- a/include/linux/context_tracking.h
> > +++ b/include/linux/context_tracking.h
> > @@ -57,6 +57,13 @@ static inline void context_tracking_task_switch(struct task_struct *prev,
> > if (context_tracking_is_enabled())
> > __context_tracking_task_switch(prev, next);
> > }
> > +
> > +static inline void context_tracking_assert_state(enum ctx_state state)
> > +{
> > + rcu_lockdep_assert(!context_tracking_is_enabled() ||
> > + this_cpu_read(context_tracking.state) == state,
> > + "context tracking state was wrong");
> > +}
>
> Please don't introduce assert() style debug check interfaces!
>
> (And RCU should be fixed too I suspect.)
The thought is to rename rcu_lockdep_assert() to RCU_LOCKDEP_WARN()
by analogy to WARN()? Easy to do if so! Or am I missing the point?
Thanx, Paul
> They are absolutely horrible on the brain when mixed with WARN_ON() interfaces,
> which are the dominant runtime check interface in the kernel.
>
> Instead make it something like:
>
> #define ct_state() (this_cpu_read(context_tracking.state))
>
> #define CT_WARN_ON(cond) \
> WARN_ON(context_tracking_is_enabled() && (cond))
>
> and then the debug checks can be written as:
>
> CT_WARN_ON(ct_state() != CONTEXT_KERNEL);
>
> This is IMHO _far_ more readable than:
>
> context_tracking_assert_state(CONTEXT_KERNEL);
>
> ok?
>
> (Assuming people will accept 'ct/CT' as an abbreviation for context tracking.)
>
> Thanks,
>
> Ingo
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists