lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Thu, 18 Jun 2015 15:42:39 +0100
From:	Catalin Marinas <catalin.marinas@....com>
To:	Maninder Singh <maninder1.s@...sung.com>
Cc:	will.deacon@....com, sungjinn.chung@...sung.com,
	jays.lee@...sung.com, kgene.kim@...sung.com,
	behanw@...verseincode.com, punit.agrawal@....com,
	mark.rutland@....com, linux-arm-kernel@...ts.infradead.org,
	linux-kernel@...r.kernel.org,
	Rohit Thapliyal <r.thapliyal@...sung.com>, pankaj.m@...sung.com
Subject: Re: [RFC][PATCH] arm64:Modify the dump mem for 64 bit addresses

On Thu, Jun 18, 2015 at 10:57:06AM +0530, Maninder Singh wrote:
> From: Rohit Thapliyal <r.thapliyal@...sung.com>
> 
> On 64bit kernel, the dump_mem gives 32 bit addresses
> on the stack dump. This gives unorganized information regarding
> the 64bit values on the stack. Hence, modified to get a complete
> 64bit memory dump.
[...]
> The above output makes a debugger life a lot more easier.
> 
> Signed-off-by: Rohit Thapliyal <r.thapliyal@...sung.com>
> Signed-off-by: Maninder Singh <maninder1.s@...sung.com>
> Reviewed-by: Akhilesh Kumar <akhilesh.k@...sung.com> 
> ---
>  arch/arm64/kernel/traps.c |   62 +++++++++++++++++++++++++++++++++++++++++++--
>  1 file changed, 60 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/arm64/kernel/traps.c b/arch/arm64/kernel/traps.c
> index 1ef2940..6e9f19b 100644
> --- a/arch/arm64/kernel/traps.c
> +++ b/arch/arm64/kernel/traps.c
> @@ -51,6 +51,48 @@ int show_unhandled_signals = 1;
>  /*
>   * Dump out the contents of some memory nicely...
>   */
> +
> +static void dump_mem64(const char *lvl, const char *str, unsigned long bottom,
> +		unsigned long top)

While I'm not against the idea, can you not add a "width" or "wide"
argument to the dump_mem() function and share the code? This function is
very similar to the original dump_mem() implementation and it would be
nice to avoid some code duplication.

-- 
Catalin
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ