lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 19 Jun 2015 09:17:37 +0100
From:	Charles Keepax <ckeepax@...nsource.wolfsonmicro.com>
To:	cw00.choi@...sung.com
Cc:	Lee Jones <lee.jones@...aro.org>,
	"myungjoo.ham@...sung.com" <myungjoo.ham@...sung.com>,
	Samuel Ortiz <sameo@...ux.intel.com>,
	devicetree <devicetree@...r.kernel.org>,
	linux-kernel <linux-kernel@...r.kernel.org>,
	patches@...nsource.wolfsonmicro.com
Subject: Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection
	DT/ACPI bindings

On Fri, Jun 19, 2015 at 11:25:57AM +0900, Chanwoo Choi wrote:
> Hi Charles,
> 
> On Thu, Jun 18, 2015 at 11:43 PM, Charles Keepax
> <ckeepax@...nsource.wolfsonmicro.com> wrote:
> > This patch adds bindings for the basic microphone detection platform
> > data.
> >
> > Signed-off-by: Charles Keepax <ckeepax@...nsource.wolfsonmicro.com>
> > ---
> > +       dbtime = 0;
> > +       device_property_read_u32(arizona->dev, "wlf,micd-dbtime", &dbtime);
> > +       switch (dbtime) {
> > +       case 2:
> 
> I'd like you to define the constant variable for specific integer
> value to improve the readability.
> e.g.,
> 
> #define MICD_DBTIME_XXX 2
> #define MICD_DBTIME_XXX 4
> 
> > +               pdata->micd_dbtime = 0x10000;
> 
> Also, you better to define the constant variable for "0x10000" to
> improbe readability in the include/linux/mfd/arizona.h. If you just
> use the hex value, the other developer cannot analyze the meaning of
> "0x10000".
> 
> > +               break;
> > +       case 4:
> 
> ditto.
> 

I am not sure these two really warrant a define the number in DT
indicates the number of debounces to perform.

#define MICD_DBTIME_TWO 2

switch (dbtime)
case MICD_DBTIME_TWO:

Is if anything less clear than just using 2 directly. I could
perhaps rename the varible to num_debounces instead?

Thanks,
Charles
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ