lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 23 Jun 2015 21:19:45 +0300
From:	"Kirill A. Shutemov" <kirill@...temov.name>
To:	Oleg Nesterov <oleg@...hat.com>
Cc:	Andy Lutomirski <luto@...capital.net>,
	Andrew Morton <akpm@...ux-foundation.org>,
	Al Viro <viro@...iv.linux.org.uk>,
	Benjamin LaHaise <bcrl@...ck.org>,
	Hugh Dickins <hughd@...gle.com>,
	Jeff Moyer <jmoyer@...hat.com>,
	Kirill Shutemov <kirill.shutemov@...ux.intel.com>,
	Linus Torvalds <torvalds@...ux-foundation.org>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	Andy Lutomirski <luto@...nel.org>,
	Pavel Emelyanov <xemul@...allels.com>
Subject: Re: [PATCH 1/1] mm: move ->mremap() from file_operations to
 vm_operations_struct

On Tue, Jun 23, 2015 at 08:02:51PM +0200, Oleg Nesterov wrote:
> vma->vm_ops->mremap() looks more natural and clean in move_vma(),
> and this way ->mremap() can have more users. Say, vdso.
> 
> Signed-off-by: Oleg Nesterov <oleg@...hat.com>
> ---
>  fs/aio.c           |   25 ++++++++++++++++---------
>  include/linux/fs.h |    1 -
>  include/linux/mm.h |    1 +
>  mm/mremap.c        |    4 ++--

Please, update Documentation/filesystems/Locking.

>  4 files changed, 19 insertions(+), 12 deletions(-)
> 
> diff --git a/fs/aio.c b/fs/aio.c
> index 9bc1335..6fe662a 100644
> --- a/fs/aio.c
> +++ b/fs/aio.c
> @@ -308,15 +308,9 @@ static void aio_free_ring(struct kioctx *ctx)
>  	}
>  }
>  
> -static int aio_ring_mmap(struct file *file, struct vm_area_struct *vma)
> -{
> -	vma->vm_flags |= VM_DONTEXPAND;
> -	vma->vm_ops = &generic_file_vm_ops;
> -	return 0;
> -}
> -
> -static int aio_ring_remap(struct file *file, struct vm_area_struct *vma)
> +static int aio_ring_remap(struct vm_area_struct *vma)

I guess aio_ring_mremap() would be a better name.

>  {
> +	struct file *file = vma->vm_file;
>  	struct mm_struct *mm = vma->vm_mm;
>  	struct kioctx_table *table;
>  	int i, res = -EINVAL;
-- 
 Kirill A. Shutemov
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ