[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <55929B0F.6060309@cogentembedded.com>
Date: Tue, 30 Jun 2015 16:35:11 +0300
From: Sergei Shtylyov <sergei.shtylyov@...entembedded.com>
To: Kris Borer <kborer@...il.com>, gregkh@...uxfoundation.org
Cc: stern@...land.harvard.edu, balbi@...com, pmladek@...e.cz,
antoine.tenart@...e-electrons.com, hdegoede@...hat.com,
rafael.j.wysocki@...el.com, linux-usb@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] usb: move assignment out of if condition
Hello.
On 6/30/2015 4:02 PM, Kris Borer wrote:
> Fix four occurrences of the checkpatch.pl error:
> ERROR: do not use assignment in if condition
> Signed-off-by: Kris Borer <kborer@...il.com>
> ---
> drivers/usb/core/hcd.c | 13 ++++++++-----
> 1 file changed, 8 insertions(+), 5 deletions(-)
> diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
> index be5b207..e268c45 100644
> --- a/drivers/usb/core/hcd.c
> +++ b/drivers/usb/core/hcd.c
[...]
> @@ -2734,7 +2735,8 @@ int usb_add_hcd(struct usb_hcd *hcd,
> /* "reset" is misnamed; its role is now one-time init. the controller
> * should already have been reset (and boot firmware kicked off etc).
> */
> - if (hcd->driver->reset && (retval = hcd->driver->reset(hcd)) < 0) {
> + retval = hcd->driver->reset(hcd);
> + if (hcd->driver->reset && retval < 0) {
If hcd->driver->reset() is NULL, this change warrants a kernel oops.
[...]
WBR, Sergei
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists