[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150701001134.GA654@swordfish>
Date: Wed, 1 Jul 2015 09:11:34 +0900
From: Sergey Senozhatsky <sergey.senozhatsky.work@...il.com>
To: David Rientjes <rientjes@...gle.com>
Cc: Sergey Senozhatsky <sergey.senozhatsky.work@...il.com>,
Andrew Morton <akpm@...ux-foundation.org>,
Michal Hocko <mhocko@...e.cz>, linux-kernel@...r.kernel.org,
linux-mm@...ck.org
Subject: Re: [patch 1/3] mm, oom: organize oom context into struct
On (06/30/15 15:46), David Rientjes wrote:
> > > There are essential elements to an oom context that are passed around to
> > > multiple functions.
> > >
> > > Organize these elements into a new struct, struct oom_context, that
> > > specifies the context for an oom condition.
> > >
> >
> > s/oom_context/oom_control/ ?
> >
>
> I think it would be confused with the existing memory.oom_control for
> memcg.
>
Hello David,
Sorry, I meant that in commit message you say
:Organize these elements into a new struct, struct oom_context, that
:specifies the context for an oom condition.
but define and use `struct oom_control' (not `struct oom_context')
[..]
+ const gfp_t gfp_mask = GFP_KERNEL;
+ struct oom_control oc = {
+ .zonelist = node_zonelist(first_memory_node, gfp_mask),
+ .nodemask = NULL,
+ .gfp_mask = gfp_mask,
+ .order = 0,
+ .force_kill = true,
+ };
+
[..]
+struct oom_control {
+ struct zonelist *zonelist;
+ nodemask_t *nodemask;
+ gfp_t gfp_mask;
+ int order;
+ bool force_kill;
+};
[..]
etc.
-ss
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists