[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150701085304.GA18268@node.dhcp.inet.fi>
Date: Wed, 1 Jul 2015 11:53:04 +0300
From: "Kirill A. Shutemov" <kirill@...temov.name>
To: David Rientjes <rientjes@...gle.com>
Cc: Sasha Levin <sasha.levin@...cle.com>, linux-mm@...ck.org,
akpm@...ux-foundation.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 05/11] mm: debug: dump page into a string rather than
directly on screen
On Tue, Jun 30, 2015 at 04:35:45PM -0700, David Rientjes wrote:
> I do understand the problem with the current VM_BUG_ON_PAGE() and
> VM_BUG_ON_VMA() stuff, and it compels me to ask about just going back to
> the normal
>
> VM_BUG_ON(cond);
>
> coupled with dump_page(), dump_vma(), dump_whatever(). It all seems so
> much simpler to me.
Is there a sensible way to couple them? I don't see much, except opencode
VM_BUG_ON():
if (IS_ENABLED(CONFIG_DEBUG_VM) && cond) {
dump_page(...);
dump_vma(...);
dump_whatever();
BUG();
}
That's too verbose to me to be usable.
BTW, I also tried[1] to solve this problem too, but people doesn't like
either.
[1] http://lkml.kernel.org/g/1412163121-4295-1-git-send-email-kirill.shutemov@linux.intel.com
--
Kirill A. Shutemov
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists