lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sat, 4 Jul 2015 00:14:41 +0300
From:	Sergei Zviagintsev <sergei@...v.net>
To:	David Herrmann <dh.herrmann@...il.com>
Cc:	linux-kernel@...r.kernel.org,
	Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
	daniel@...que.org, tixxdz@...ndz.org
Subject: Re: [PATCH 2/6] kdbus: drop redundant KDBUS_MSG_MAX_ITEMS

Hi,

On Thu, Jul 02, 2015 at 10:28:30AM +0200, David Herrmann wrote:
> We already limit the size of the message object, there's no reason to add
> an arbitrary additional limit on the number of items. We don't do this for
> other item-arrays, so lets stop restricting the messages in this way.
> 
> Signed-off-by: David Herrmann <dh.herrmann@...il.com>
> ---
>  ipc/kdbus/limits.h  | 3 ---
>  ipc/kdbus/message.c | 3 ---
>  2 files changed, 6 deletions(-)
> 
> diff --git a/ipc/kdbus/limits.h b/ipc/kdbus/limits.h
> index 6450f58..c54925a 100644
> --- a/ipc/kdbus/limits.h
> +++ b/ipc/kdbus/limits.h
> @@ -19,9 +19,6 @@
>  /* maximum size of message header and items */
>  #define KDBUS_MSG_MAX_SIZE		SZ_8K
>  
> -/* maximum number of message items */
> -#define KDBUS_MSG_MAX_ITEMS		128
> -
>  /* maximum number of memfd items per message */
>  #define KDBUS_MSG_MAX_MEMFD_ITEMS	16
>  
> diff --git a/ipc/kdbus/message.c b/ipc/kdbus/message.c
> index 066e816..c499014 100644
> --- a/ipc/kdbus/message.c
> +++ b/ipc/kdbus/message.c
> @@ -263,9 +263,6 @@ static int kdbus_msg_scan_items(struct kdbus_kmsg *kmsg,
>  		size_t payload_size = KDBUS_ITEM_PAYLOAD_SIZE(item);
>  		struct iovec *iov = kmsg->iov + kmsg->iov_count;
>  
> -		if (++n > KDBUS_MSG_MAX_ITEMS)
> -			return -E2BIG;
> -

This change makes useless assigning `n' to zero at line 260. Also `n'
could be renamed to smt like `n_res' or dropped.

>  		switch (item->type) {
>  		case KDBUS_ITEM_PAYLOAD_VEC: {
>  			struct kdbus_msg_data *d = res->data + res->data_count;
> -- 
> 2.4.5
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ