[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150706112653.GC3644@twins.programming.kicks-ass.net>
Date: Mon, 6 Jul 2015 13:26:53 +0200
From: Peter Zijlstra <peterz@...radead.org>
To: byungchul.park@....com
Cc: mingo@...nel.org, minchan.kim@....com, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/1] sched: make update_min_vruntime() more readable
On Sun, Jul 05, 2015 at 06:33:48PM +0900, byungchul.park@....com wrote:
> From: Byungchul Park <byungchul.park@....com>
>
> update_min_vruntime() condition flow can be simpler
This changelog needs help; a few more words on why this is correct and
simpler would not go amiss, and you should mention you're deleting some
spurious trailing whitespace.
> Signed-off-by: Byungchul Park <byungchul.park@....com>
> ---
> kernel/sched/fair.c | 17 +++++++----------
> 1 file changed, 7 insertions(+), 10 deletions(-)
>
> diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
> index 3d57cc0..59de964 100644
> --- a/kernel/sched/fair.c
> +++ b/kernel/sched/fair.c
> @@ -463,20 +463,17 @@ static void update_min_vruntime(struct cfs_rq *cfs_rq)
> {
> u64 vruntime = cfs_rq->min_vruntime;
>
> - if (cfs_rq->curr)
> - vruntime = cfs_rq->curr->vruntime;
> -
> if (cfs_rq->rb_leftmost) {
> struct sched_entity *se = rb_entry(cfs_rq->rb_leftmost,
> struct sched_entity,
> run_node);
>
> - if (!cfs_rq->curr)
> - vruntime = se->vruntime;
> - else
> - vruntime = min_vruntime(vruntime, se->vruntime);
> + vruntime = se->vruntime;
> }
>
> + if (cfs_rq->curr)
> + vruntime = min_vruntime(vruntime, cfs_rq->curr->vruntime);
> +
> /* ensure we never gain time by being placed backwards. */
> cfs_rq->min_vruntime = max_vruntime(cfs_rq->min_vruntime, vruntime);
> #ifndef CONFIG_64BIT
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists