lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 8 Jul 2015 08:08:27 +0000
From:	Phil Edworthy <phil.edworthy@...esas.com>
To:	Laurent Pinchart <laurent.pinchart@...asonboard.com>
CC:	Yoshihiro Shimoda <yoshihiro.shimoda.uh@...esas.com>,
	Kuninori Morimoto <kuninori.morimoto.gx@...esas.com>,
	Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
	Felipe Balbi <balbi@...com>,
	Ulrich Hecht <ulrich.hecht@...il.com>,
	Kishon Vijay Abraham I <kishon@...com>,
	"Sergei Shtylyov" <sergei.shtylyov@...entembedded.com>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	"linux-usb@...r.kernel.org" <linux-usb@...r.kernel.org>,
	"linux-sh@...r.kernel.org" <linux-sh@...r.kernel.org>
Subject: RE: [PATCH v5] usb: renesas_usbhs: Allow an OTG PHY driver to provide
 VBUS

Hi Laurent,

On 08 July 2015 00:08, Laurent wrote:
> Hi Phil,
> 
> Thank you for the patch.
> 
> On Tuesday 07 July 2015 12:52:43 Phil Edworthy wrote:
> > These changes allow a PHY driver to trigger a VBUS interrupt and
> > to provide the value of VBUS.
> >
> > Signed-off-by: Phil Edworthy <phil.edworthy@...esas.com>
> 
> This looks much better to me. I just have two comments, please see below.
> 
> > ---
> > v5:
> >   - Avoid race when vbus_is_indirect may or may not be read
> >     before the phy has called vbus_session. In doing so, the
> >     changes have also been isolated to mod_gadget.c
> >
> > v4:
> >   - Use true/false with bool vars.
> >   - Clean up "transceiver found" message.
> >
> > v3:
> >   - Changed how indirect vbus is plumbed in.
> >   - Removed unnecessary (void) on call to otg_set_peripheral.
> >   - Moved code that connects to bus through transceiver so it
> >     is before setting gpriv->driver.
> >
> > v2:
> >   - vbus variables changed from int to bool.
> >   - dev_info() changed to dev_err()
> > ---
> >  drivers/usb/renesas_usbhs/mod_gadget.c | 62
> +++++++++++++++++++++++++++++++
> >  1 file changed, 62 insertions(+)
> >
> > diff --git a/drivers/usb/renesas_usbhs/mod_gadget.c
> > b/drivers/usb/renesas_usbhs/mod_gadget.c index dc2aa32..19a22a3 100644
> > --- a/drivers/usb/renesas_usbhs/mod_gadget.c
> > +++ b/drivers/usb/renesas_usbhs/mod_gadget.c
> > @@ -21,6 +21,7 @@
> >  #include <linux/platform_device.h>
> >  #include <linux/usb/ch9.h>
> >  #include <linux/usb/gadget.h>
> > +#include <linux/usb/otg.h>
> >  #include "common.h"
> >
> >  /*
> > @@ -50,6 +51,8 @@ struct usbhsg_gpriv {
> >  	int			 uep_size;
> >
> >  	struct usb_gadget_driver	*driver;
> > +	struct usb_phy		*transceiver;
> > +	bool 			 vbus_indirect_value;
> 
> How about naming this vbus_connected ? A boolean "value" doesn't mean much.
Hmm, vbus_connected isn't right either. This variable directly maps to the vbus
signal, i.e. this variable is true when the signal is high. I'll change it to
vbus_active.

> >
> >  	u32	status;
> >  #define USBHSG_STATUS_STARTED		(1 << 0)
> > @@ -873,6 +876,27 @@ static int usbhsg_try_stop(struct usbhs_priv *priv, u32
> > status) }
> >
> >  /*
> > + * VBUS provided by the PHY
> > + */
> > +static int usbhsm_phy_get_vbus(struct platform_device *pdev)
> > +{
> > +	struct usbhs_priv *priv = usbhs_pdev_to_priv(pdev);
> > +	struct usbhsg_gpriv *gpriv = usbhsg_priv_to_gpriv(priv);
> > +
> > +	return  gpriv->vbus_indirect_value;
> > +}
> > +
> > +static void usbhs_mod_phy_mode(struct usbhs_priv *priv)
> > +{
> > +	struct usbhs_mod_info *info = &priv->mod_info;
> > +
> > +	info->irq_vbus		= NULL;
> > +	priv->pfunc.get_vbus	= usbhsm_phy_get_vbus;
> > +
> > +	usbhs_irq_callback_update(priv, NULL);
> > +}
> > +
> > +/*
> >   *
> >   *		linux usb function
> >   *
> > @@ -882,12 +906,28 @@ static int usbhsg_gadget_start(struct usb_gadget
> > *gadget, {
> >  	struct usbhsg_gpriv *gpriv = usbhsg_gadget_to_gpriv(gadget);
> >  	struct usbhs_priv *priv = usbhsg_gpriv_to_priv(gpriv);
> > +	struct device *dev = usbhs_priv_to_dev(priv);
> > +	int ret;
> >
> >  	if (!driver		||
> >  	    !driver->setup	||
> >  	    driver->max_speed < USB_SPEED_FULL)
> >  		return -EINVAL;
> >
> > +	/* connect to bus through transceiver */
> > +	if (!IS_ERR_OR_NULL(gpriv->transceiver)) {
> > +		ret = otg_set_peripheral(gpriv->transceiver->otg,
> > +					&gpriv->gadget);
> > +		if (ret) {
> > +			dev_err(dev, "%s: can't bind to transceiver\n",
> > +				gpriv->gadget.name);
> > +			return ret;
> > +		}
> > +
> > +		/* get vbus using phy versions */
> > +		usbhs_mod_phy_mode(priv);
> 
> Given that the presence of an external PHY is known at probe time, couldn't
> this call be moved to the probe function ? It would then probably conflict
> with the usbhs_mod_autonomy_mode() call from usbhs_probe(), which would
> need to be fixed.
You could do this, but as you say it would conflict with usbhs_probe(). I can't
see a simple way to check for the external phy connection, so I would prefer to
keep it here.
Is that ok?
 
> > +	}
> > +
> >  	/* first hook up the driver ... */
> >  	gpriv->driver = driver;
> >
> > @@ -900,6 +940,10 @@ static int usbhsg_gadget_stop(struct usb_gadget
> > *gadget) struct usbhs_priv *priv = usbhsg_gpriv_to_priv(gpriv);
> >
> >  	usbhsg_try_stop(priv, USBHSG_STATUS_REGISTERD);
> > +
> > +	if (!IS_ERR_OR_NULL(gpriv->transceiver))
> > +		otg_set_peripheral(gpriv->transceiver->otg, NULL);
> > +
> >  	gpriv->driver = NULL;
> >
> >  	return 0;
> > @@ -947,12 +991,26 @@ static int usbhsg_set_selfpowered(struct usb_gadget
> > *gadget, int is_self) return 0;
> >  }
> >
> > +static int usbhsg_vbus_session(struct usb_gadget *gadget, int is_active)
> > +{
> > +	struct usbhsg_gpriv *gpriv = usbhsg_gadget_to_gpriv(gadget);
> > +	struct usbhs_priv *priv = usbhsg_gpriv_to_priv(gpriv);
> > +	struct platform_device *pdev = usbhs_priv_to_pdev(priv);
> > +
> > +	gpriv->vbus_indirect_value = !!is_active;
> > +
> > +	renesas_usbhs_call_notify_hotplug(pdev);
> > +
> > +	return 0;
> > +}
> > +
> >  static const struct usb_gadget_ops usbhsg_gadget_ops = {
> >  	.get_frame		= usbhsg_get_frame,
> >  	.set_selfpowered	= usbhsg_set_selfpowered,
> >  	.udc_start		= usbhsg_gadget_start,
> >  	.udc_stop		= usbhsg_gadget_stop,
> >  	.pullup			= usbhsg_pullup,
> > +	.vbus_session		= usbhsg_vbus_session,
> >  };
> >
> >  static int usbhsg_start(struct usbhs_priv *priv)
> > @@ -994,6 +1052,10 @@ int usbhs_mod_gadget_probe(struct usbhs_priv
> *priv)
> >  		goto usbhs_mod_gadget_probe_err_gpriv;
> >  	}
> >
> > +	gpriv->transceiver = usb_get_phy(USB_PHY_TYPE_UNDEFINED);
> > +	dev_info(dev, "%stransceiver found\n",
> > +		 gpriv->transceiver ? "" : "no ");
> > +
> >  	/*
> >  	 * CAUTION
> >  	 *
> 
> --
> Regards,
> 
> Laurent Pinchart

Thanks
Phil
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ