[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20150709163156.GF20855@e104818-lin.cambridge.arm.com>
Date: Thu, 9 Jul 2015 17:31:56 +0100
From: Catalin Marinas <catalin.marinas@....com>
To: Maninder Singh <maninder1.s@...sung.com>
Cc: will.deacon@....com, sungjinn.chung@...sung.com,
jays.lee@...sung.com, kgene.kim@...sung.com,
vladimir.murzin@....com, behanw@...verseincode.com,
punit.agrawal@....com, mark.rutland@....com,
linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org,
Rohit Thapliyal <r.thapliyal@...sung.com>, pankaj.m@...sung.com
Subject: Re: [PATCH v4] arm64:Modify the dump mem for 64 bit addresses
On Thu, Jul 09, 2015 at 11:30:34AM +0530, Maninder Singh wrote:
> diff --git a/arch/arm64/kernel/traps.c b/arch/arm64/kernel/traps.c
> index 1ef2940..97e6208 100644
> --- a/arch/arm64/kernel/traps.c
> +++ b/arch/arm64/kernel/traps.c
> @@ -52,11 +52,12 @@ int show_unhandled_signals = 1;
> * Dump out the contents of some memory nicely...
> */
> static void dump_mem(const char *lvl, const char *str, unsigned long bottom,
> - unsigned long top)
> + unsigned long top, bool wide)
> {
> unsigned long first;
> mm_segment_t fs;
> int i;
> + unsigned int width = wide ? 4 : 8;
I was thinking the other way around, i.e. wide means 64-bit, narrow
32-bit.
Anyway, just rename "wide" to "compat" here, it makes even more sense.
The rest of the patch looks fine:
Reviewed-by: Catalin Marinas <catalin.marinas@....com>
Will can pick it up for 4.3.
Thanks.
--
Catalin
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists