[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150711012513.GB811@swordfish>
Date: Sat, 11 Jul 2015 10:25:13 +0900
From: Sergey Senozhatsky <sergey.senozhatsky@...il.com>
To: Andrew Morton <akpm@...ux-foundation.org>
Cc: Sergey Senozhatsky <sergey.senozhatsky.work@...il.com>,
Johannes Weiner <hannes@...xchg.org>,
Minchan Kim <minchan@...nel.org>, linux-mm@...ck.org,
linux-kernel@...r.kernel.org,
Sergey Senozhatsky <sergey.senozhatsky@...il.com>
Subject: Re: [RFC] mm/shrinker: define INIT_SHRINKER macro
On (07/10/15 15:32), Andrew Morton wrote:
> > Shrinker API does not handle nicely unregister_shrinker() on a not-registered
> > ->shrinker. Looking at shrinker users, they all have to (a) carry on some sort
> > of a flag telling that "unregister_shrinker()" will not blow up... or (b) just
> > be fishy
> >
> > ...
> >
> > I was thinking of a trivial INIT_SHRINKER macro to init `struct shrinker'
> > internal members (composed in email client, not tested)
> >
> > include/linux/shrinker.h
> >
> > #define INIT_SHRINKER(s) \
> > do { \
> > (s)->nr_deferred = NULL; \
> > INIT_LIST_HEAD(&(s)->list); \
> > } while (0)
>
> Spose so. Although it would be simpler to change unregister_shrinker()
> to bale out if list.next==NULL and then say "all zeroes is the
> initialized state".
Yes, or '->nr_deferred == NULL' -- we can't have NULL ->nr_deferred
in a properly registered shrinker (as of now)
register_shrinker()
...
shrinker->nr_deferred = kzalloc(size, GFP_KERNEL);
if (!shrinker->nr_deferred)
return -ENOMEM;
down_write(&shrinker_rwsem);
list_add_tail(&shrinker->list, &shrinker_list);
up_write(&shrinker_rwsem);
return 0;
...
But that will not work if someone has accidentally passed not zeroed
out pointer to unregister.
e.g.
...
struct foo *bar = kmalloc(..) /* no __GFP_ZERO */
... something goes wrong and we 'goto err' before
shrinker_register()
err:
unregister_shrinker(&bar->shrinker);
...
->list.next and ->nr_deferred won't help us here.
That was the reason to have INIT_SHRINKER/shrinker_init().
But adding an additional check to unregister_shrinker() will not harm.
> > --- a/include/linux/shrinker.h
> > +++ b/include/linux/shrinker.h
> > @@ -63,6 +63,12 @@ struct shrinker {
> > };
> > #define DEFAULT_SEEKS 2 /* A good number if you don't know better. */
> >
> > +#define INIT_SHRINKER(s) \
> > + do { \
> > + INIT_LIST_HEAD(&(s)->list); \
> > + (s)->nr_deferred = NULL; \
> > + } while (0)
> > +
>
> The only reason to make this a macro would be so that it can be used at
> compile-time, with something like
>
> static struct shrinker my_shrinker = INIT_SHRINKER(&my_shrinker);
>
> But as we're not planning on doing that, we implement it in C, please.
>
> Also, shrinker_init() would be a better name. Although we already
> mucked up shrinker_register() and shrinker_unregister().
>
Sure. Will do. Thanks.
-ss
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists