[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <55B21189.8030901@citrix.com>
Date: Fri, 24 Jul 2015 11:20:57 +0100
From: Julien Grall <julien.grall@...rix.com>
To: David Vrabel <david.vrabel@...rix.com>,
<xen-devel@...ts.xenproject.org>
CC: <linux-kernel@...r.kernel.org>,
Boris Ostrovsky <boris.ostrovsky@...cle.com>,
<ian.campbell@...rix.com>, <linux-arm-kernel@...ts.infradead.org>,
<stefano.stabellini@...citrix.com>
Subject: Re: [Xen-devel] [PATCH v2 02/20] xen: Introduce a function to split
a Linux page into Xen page
On 24/07/15 11:10, David Vrabel wrote:
> On 24/07/15 10:54, Julien Grall wrote:
>> On 24/07/15 10:31, David Vrabel wrote:
>>> On 09/07/15 21:42, Julien Grall wrote:
>>>> The Xen interface is always using 4KB page. This means that a Linux page
>>>> may be split across multiple Xen page when the page granularity is not
>>>> the same.
>>>>
>>>> This helper will break down a Linux page into 4KB chunk and call the
>>>> helper on each of them.
>>> [...]
>>>> --- a/include/xen/page.h
>>>> +++ b/include/xen/page.h
>>>> @@ -39,4 +39,24 @@ struct xen_memory_region xen_extra_mem[XEN_EXTRA_MEM_MAX_REGIONS];
>>>>
>>>> extern unsigned long xen_released_pages;
>>>>
>>>> +typedef int (*xen_pfn_fn_t)(struct page *page, unsigned long pfn, void *data);
>>>> +
>>>> +/* Break down the page in 4KB granularity and call fn foreach xen pfn */
>>>> +static inline int xen_apply_to_page(struct page *page, xen_pfn_fn_t fn,
>>>> + void *data)
>>>
>>> I think this should be outlined (unless you have measurements that
>>> support making it inlined).
>>
>> I don't have any performance measurements. Although, when Linux is using
>> 4KB page granularity, the loop in this helper will be dropped by the
>> helper. The code would look like:
>>
>> unsigned long pfn = xen_page_to_pfn(page);
>>
>> ret = fn(page, fn, data);
>> if (ret)
>> return ret;
>>
>> The compiler could even inline the callback (fn). So it drops 2
>> functions call.
>
> Ok, keep it inlined.
>
>>> Also perhaps make it
>>>
>>> int xen_for_each_gfn(struct page *page,
>>> xen_gfn_fn_t fn, void *data);
>>
>> gfn standing for Guest Frame Number right?
>
> Yes. This suggestion is just changing the name to make it more obvious
> what it does.
I will change the name.
Regards,
--
Julien Grall
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists