lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 24 Jul 2015 13:52:27 +0300
From:	Dan Carpenter <dan.carpenter@...cle.com>
To:	Joshua Clayton <stillcompiling@...il.com>
Cc:	Larry Finger <Larry.Finger@...inger.net>,
	Florian Schilhabel <florian.c.schilhabel@...glemail.com>,
	Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
	devel@...verdev.osuosl.org,
	Tapasweni Pathak <tapaswenipathak@...il.com>,
	Vaishali Thakkar <vthakkar1994@...il.com>,
	Nitin Kuppelur <nitinkuppelur@...il.com>,
	linux-kernel@...r.kernel.org,
	Sudip Mukherjee <sudipm.mukherjee@...il.com>
Subject: Re: [PATCH 5/5] staging: rtl8712: style fix:

Write a better subject line.

On Thu, Jul 23, 2015 at 09:53:18PM -0700, Joshua Clayton wrote:
> change instances SupportedRates to compliant and sane "rates"
> This change in no way harms readability, and brings several lines
> under the 80 character limit.
> 

Yeah, but it does a some other stuff as well like removing casts.

> -		while ((pcur_bss->SupportedRates[i] != 0) &&
> -			(pcur_bss->SupportedRates[i] != 0xFF)) {
> -			rate = pcur_bss->SupportedRates[i] & 0x7F;
> +		while (pcur_bss->rates[i] && (pcur_bss->rates[i] != 0xFF)) {
> +			rate = pcur_bss->rates[i] & 0x7F;
>  			if (rate > max_rate)
>  				max_rate = rate;
>  			wrqu->bitrate.fixed = 0;	/* no auto select */

I actually like the != 0 here because we're talking about the number
zero.  It should look like this:

		while (pcur_bss->rates[i] != 0 &&
		       pcur_bss->rates[i] != 0xFF) {

But removing the parens is something for a different patch.  I use a
script to help review these so when you mix different changes together
it means there is more manual review work for me.

regards,
dan carpenter

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ