[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150729105003.GB30872@techsingularity.net>
Date: Wed, 29 Jul 2015 11:50:03 +0100
From: Mel Gorman <mgorman@...hsingularity.net>
To: Gioh Kim <gioh.kim@....com>
Cc: jlayton@...chiereds.net, bfields@...ldses.org, vbabka@...e.cz,
iamjoonsoo.kim@....com, viro@...iv.linux.org.uk, mst@...hat.com,
koct9i@...il.com, minchan@...nel.org, aquini@...hat.com,
linux-fsdevel@...r.kernel.org,
virtualization@...ts.linux-foundation.org,
linux-kernel@...r.kernel.org, linux-api@...r.kernel.org,
linux-mm@...ck.org, dri-devel@...ts.freedesktop.org,
akpm@...ux-foundation.org, Gioh Kim <gurugio@...mail.net>
Subject: Re: [PATCH 1/4] fs/anon_inodes: new interface to create new inode
On Mon, Jul 13, 2015 at 05:35:16PM +0900, Gioh Kim wrote:
> From: Gioh Kim <gurugio@...mail.net>
>
> The anon_inodes has already complete interfaces to create manage
> many anonymous inodes but don't have interface to get
> new inode. Other sub-modules can create anonymous inode
> without creating and mounting it's own pseudo filesystem.
>
> Signed-off-by: Gioh Kim <gioh.kim@....com>
> Acked-by: Rafael Aquini <aquini@...hat.com>
This is my first run through the series so I'm going to miss details but
this patch confuses me a little. You create an inode to associate with
the balloon dev_info so that page->mapping can be assigned. It's only the
mapping you care about for the aops so why are multiple inodes required? A
driver should be able to share and reference count a single inode. The
motivation to do it that way would be to reduce memory consumption and
this series is motivated by embedded platforms.
anon_inode_getfd has the following
* Creates a new file by hooking it on a single inode. This is useful for files
* that do not need to have a full-fledged inode in order to operate correctly.
* All the files created with anon_inode_getfd() will share a single inode,
* hence saving memory and avoiding code duplication for the file/inode/dentry
* setup. Returns new descriptor or an error code.
If all we care about the inode is the aops then it would follow that
anon_inode_getfd() is ideal. The tradeoff is reference counting overhead.
The changelog needs to explain why anon_inode_getfd() cannot be used.
--
Mel Gorman
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists