[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150801144752.GA664@roeck-us.net>
Date: Sat, 1 Aug 2015 07:47:52 -0700
From: Guenter Roeck <linux@...ck-us.net>
To: Ulrich Obergfell <uobergfe@...hat.com>
Cc: linux-kernel@...r.kernel.org, akpm@...ux-foundation.org,
dzickus@...hat.com, atomlin@...hat.com, jolsa@...nel.org,
mhocko@...e.cz, eranian@...gle.com, cmetcalf@...hip.com,
fweisbec@...il.com
Subject: Re: [PATCH 2/4] watchdog: introduce watchdog_suspend() and
watchdog_resume()
On Sat, Aug 01, 2015 at 10:39:22AM -0400, Ulrich Obergfell wrote:
> > ----- Original Message -----
> > From: "Guenter Roeck" <linux@...ck-us.net>
> > ...
> > Subject: Re: [PATCH 2/4] watchdog: introduce watchdog_suspend() and watchdog_resume()
> >
> > On Sat, Aug 01, 2015 at 02:49:23PM +0200, Ulrich Obergfell wrote:
> >> This interface can be utilized to deactivate the hard and soft lockup
> >> detector temporarily. Callers are expected to minimize the duration of
> >> deactivation. Multiple deactivations are allowed to occur in parallel
> >> but should be rare in practice.
> >>
> >> Signed-off-by: Ulrich Obergfell <uobergfe@...hat.com>
> >> ---
> >> include/linux/nmi.h | 2 ++
> >> kernel/watchdog.c | 65 +++++++++++++++++++++++++++++++++++++++++++++++++++++
> >> 2 files changed, 67 insertions(+)
> >>
> >> diff --git a/include/linux/nmi.h b/include/linux/nmi.h
> >> index f94da0e..60050c2 100644
> >> --- a/include/linux/nmi.h
> >> +++ b/include/linux/nmi.h
> >> @@ -80,6 +80,8 @@ extern int proc_watchdog_thresh(struct ctl_table *, int ,
> >> void __user *, size_t *, loff_t *);
> >> extern int proc_watchdog_cpumask(struct ctl_table *, int,
> >> void __user *, size_t *, loff_t *);
> >> +extern int watchdog_suspend(void);
> >> +extern void watchdog_resume(void);
> >
> > How about nmi_watchdog_enable() and nmi_watchdog_disable() to avoid confusion
> > with the watchdog subsystem ?
>
> Guenter,
>
> Good point. However, I would like to avoid the 'nmi_' prefix in the
> function names as it could be misleading. watchdog_{suspend|resume}
> affect both -the hard and soft lockup detector- so I think function
> names like
>
> lockup_detector_suspend() instead of watchdog_suspend()
> lockup_detector_resume() instead of watchdog_resume()
>
> would summarize better what these functions are intended to be used
> for. The above names would also be consistent with the existing name
>
> lockup_detector_init()
>
Makes sense.
Thanks,
Guenter
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists