[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150804175616.GA28971@redhat.com>
Date: Tue, 4 Aug 2015 13:56:16 -0400
From: Mike Snitzer <snitzer@...hat.com>
To: Christoph Hellwig <hch@....de>
Cc: Jens Axboe <axboe@...com>, linux-api@...r.kernel.org,
dm-devel@...hat.com, linux-nvme@...ts.infradead.org,
linux-scsi@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 4/6] dm: refactor ioctl handling
On Tue, Aug 04 2015 at 3:11am -0400,
Christoph Hellwig <hch@....de> wrote:
> This moves the call to blkdev_ioctl and the argument checking to core code,
> and only leaves a callout to find the block device to operate on it the
> targets. This will simplifies the code and will allow us to pass through
> ioctl-like command using other methods in the next patch.
>
> Signed-off-by: Christoph Hellwig <hch@....de>
...
> diff --git a/drivers/md/dm.c b/drivers/md/dm.c
> index f331d88..c68eb91 100644
> --- a/drivers/md/dm.c
> +++ b/drivers/md/dm.c
> @@ -584,7 +584,17 @@ retry:
> goto out;
> }
>
> - r = tgt->type->ioctl(tgt, cmd, arg);
> + r = tgt->type->ioctl(tgt, &bdev, &mode);
> + if (r < 0)
> + goto out;
> +
> + if (r > 0) {
> + r = scsi_verify_blk_ioctl(NULL, cmd);
> + if (r)
> + goto out;
> + }
> +
> + r = __blkdev_driver_ioctl(bdev, mode, cmd, arg);
>
> out:
> dm_put_live_table(md, srcu_idx);
> diff --git a/include/linux/device-mapper.h b/include/linux/device-mapper.h
> index 51cc1de..9b73138 100644
> --- a/include/linux/device-mapper.h
> +++ b/include/linux/device-mapper.h
> @@ -79,8 +79,8 @@ typedef void (*dm_status_fn) (struct dm_target *ti, status_type_t status_type,
>
> typedef int (*dm_message_fn) (struct dm_target *ti, unsigned argc, char **argv);
>
> -typedef int (*dm_ioctl_fn) (struct dm_target *ti, unsigned int cmd,
> - unsigned long arg);
> +typedef int (*dm_ioctl_fn) (struct dm_target *ti,
> + struct block_device **bdev, fmode_t *mode);
>
> typedef int (*dm_merge_fn) (struct dm_target *ti, struct bvec_merge_data *bvm,
> struct bio_vec *biovec, int max_size);
This should be renamed to dm_prepare_ioctl_fn and the targets' hook
would be .prepare_ioctl
Open to other names but if the targets no longer issue the ioctl there
is little point to call it .ioctl
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists