[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150807115710.GA16897@redhat.com>
Date: Fri, 7 Aug 2015 13:57:10 +0200
From: Oleg Nesterov <oleg@...hat.com>
To: Vineet Gupta <Vineet.Gupta1@...opsys.com>
Cc: Alexander Viro <viro@...iv.linux.org.uk>,
"Peter Zijlstra (Intel)" <peterz@...radead.org>,
linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] coredump: Replace opencoded set_mask_bits()
On 08/07, Vineet Gupta wrote:
>
> --- a/fs/exec.c
> +++ b/fs/exec.c
> @@ -1690,15 +1690,10 @@ EXPORT_SYMBOL(set_binfmt);
> */
> void set_dumpable(struct mm_struct *mm, int value)
> {
> - unsigned long old, new;
> -
> if (WARN_ON((unsigned)value > SUID_DUMP_ROOT))
> return;
>
> - do {
> - old = ACCESS_ONCE(mm->flags);
> - new = (old & ~MMF_DUMPABLE_MASK) | value;
> - } while (cmpxchg(&mm->flags, old, new) != old);
> + set_mask_bits(&mm->flags, MMF_DUMPABLE_MASK, value);
> }
Acked-by: Oleg Nesterov <oleg@...hat.com>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists