lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 19 Aug 2015 13:50:22 +0300
From:	Dan Carpenter <dan.carpenter@...cle.com>
To:	Raphaël Beamonte <raphael.beamonte@...il.com>
Cc:	Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
	devel@...verdev.osuosl.org,
	Ksenija Stanojevic <ksenija.stanojevic@...il.com>,
	Greg Donald <gdonald@...il.com>, linux-kernel@...r.kernel.org,
	Cristina Opriceana <cristina.opriceana@...il.com>,
	Joe Perches <joe@...ches.com>,
	Sudip Mukherjee <sudipm.mukherjee@...il.com>
Subject: Re: [PATCHv2 19/19] staging: rtl8192u: r8192U_core: fix line over 80
 characters code style issue

On Tue, Aug 18, 2015 at 12:58:20PM -0400, Raphaël Beamonte wrote:
> Light code refactoring to keep the lines under 80 characters to follow
> the kernel code style.
> 

The first patches seem fine but this one is too hard to review...
Divide it up somehow.  Maybe:

patch #1: comments
patch #2: add line breaks
patch #3: add temporary variables
patch #4: reverse conditions

I have looked through this patch a little, and I am skepitcal of some
of these changes.  Do they really improve readability?


-                               if (TempCCk == priv->cck_txbbgain_table[i].ccktxbb_valuearray[0]) {
-                                       priv->cck_present_attentuation_20Mdefault = (u8)i;
-                                       break;
-                               }
+                               if (TempCCk !=
+                                   priv->cck_txbbgain_table[i].
+                                               ccktxbb_valuearray[0])
+                                       continue;


regards,
dan carpenter

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ