lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Fri, 21 Aug 2015 14:22:40 +0000
From:	"Liang, Kan" <kan.liang@...el.com>
To:	Jiri Olsa <jolsa@...hat.com>
CC:	"acme@...nel.org" <acme@...nel.org>,
	"a.p.zijlstra@...llo.nl" <a.p.zijlstra@...llo.nl>,
	"luto@...nel.org" <luto@...nel.org>,
	"mingo@...hat.com" <mingo@...hat.com>,
	"eranian@...gle.com" <eranian@...gle.com>,
	"ak@...ux.intel.com" <ak@...ux.intel.com>,
	"mark.rutland@....com" <mark.rutland@....com>,
	"Hunter, Adrian" <adrian.hunter@...el.com>,
	"jolsa@...nel.org" <jolsa@...nel.org>,
	"namhyung@...nel.org" <namhyung@...nel.org>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: RE: [PATCH V4 1/7] perf,tools: introduce generic FEAT for CPU
 attributes

> 
> On Tue, Aug 18, 2015 at 10:16:35AM -0400, Kan Liang wrote:
> 
> SNIP
> 
> > diff --git a/tools/perf/util/header.h b/tools/perf/util/header.h index
> > 9b53b65..233c24d 100644
> > --- a/tools/perf/util/header.h
> > +++ b/tools/perf/util/header.h
> > @@ -31,6 +31,7 @@ enum {
> >  	HEADER_PMU_MAPPINGS,
> >  	HEADER_GROUP_DESC,
> >  	HEADER_AUXTRACE,
> > +	HEADER_CPU_ATTR,
> >  	HEADER_LAST_FEATURE,
> >  	HEADER_FEAT_BITS	= 256,
> >  };
> > @@ -66,6 +67,11 @@ struct perf_header;  int
> > perf_file_header__read(struct perf_file_header *header,
> >  			   struct perf_header *ph, int fd);
> >
> > +enum perf_header_cpu_attr {
> > +	PERF_HEADER_CPU_MAX_FREQ	= 0,
> > +	PERF_HEADER_CPU_ATTR_MAX,
> > +};
> > +
> >  struct perf_session_env {
> >  	char			*hostname;
> >  	char			*os_release;
> > @@ -75,6 +81,7 @@ struct perf_session_env {
> >  	int			nr_cpus_avail;
> >  	char			*cpu_desc;
> >  	char			*cpuid;
> > +	u64			cpu_attr[PERF_HEADER_CPU_ATTR_MAX];
> 
> it'd more readable having struct with all fields instead of the tag accesible
> array

Do you mean replace cpu_attr[] to something like this?

@@ -89,6 +95,9 @@ struct perf_session_env {
        char                    *sibling_threads;
        char                    *numa_nodes;
        char                    *pmu_mappings;
+       struct {
+               u64             freq;
+       }                       cpu_attr;


Thanks,
Kan
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ