[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1440722847.31670.1@remotesmtp.freescale.net>
Date: Fri, 28 Aug 2015 08:47:27 +0800
From: Chenhui Zhao <chenhui.zhao@...escale.com>
To: Scott Wood <scottwood@...escale.com>
CC: <linuxppc-dev@...ts.ozlabs.org>, <linux-kernel@...r.kernel.org>,
<Jason.Jin@...escale.com>
Subject: Re: [PATCH v2,4/5] PowerPC/mpc85xx: Add hotplug support on E5500
and E500MC cores
On Thu, Aug 27, 2015 at 4:55 AM, Scott Wood <scottwood@...escale.com>
wrote:
> On Wed, Aug 26, 2015 at 08:09:47PM +0800, Chenhui Zhao wrote:
>> +int check_cpu_dead(unsigned int cpu)
>> +{
>> + return per_cpu(cpu_state, cpu) == CPU_DEAD;
>> +}
>
> I'm not sure this needs to be a function versus open-coded, but if
> you do
> want to make it a function, make it more obvious from the caller side
> by
> changing it to:
>
> bool is_cpu_dead(unsigned int cpu);
>
> Otherwise if I see "if (check_cpu_dead(cpu))" I don't know if the
> if-block is executed if the CPU is dead or if it isn't.
OK.
>
>
>> diff --git a/arch/powerpc/platforms/85xx/smp.h
>> b/arch/powerpc/platforms/85xx/smp.h
>> index 0b20ae3..8ee19a3 100644
>> --- a/arch/powerpc/platforms/85xx/smp.h
>> +++ b/arch/powerpc/platforms/85xx/smp.h
>> @@ -6,6 +6,7 @@
>> #ifdef CONFIG_SMP
>> void __init mpc85xx_smp_init(void);
>> int __init mpc85xx_setup_pmc(void);
>> +int __init fsl_rcpm_init(void);
>> #else
>
> Why wasn't this added in the patch that added fsl_rcpm_init()?
>
> -Scott
Will move it to there.
Thanks,
-Chenhui
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists