[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <55E9C45F.60407@suse.cz>
Date: Fri, 4 Sep 2015 18:18:39 +0200
From: Vlastimil Babka <vbabka@...e.cz>
To: Ebru Akagunduz <ebru.akagunduz@...il.com>, linux-mm@...ck.org
Cc: akpm@...ux-foundation.org, kirill.shutemov@...ux.intel.com,
n-horiguchi@...jp.nec.com, aarcange@...hat.com, riel@...hat.com,
iamjoonsoo.kim@....com, xiexiuqi@...wei.com, gorcunov@...nvz.org,
linux-kernel@...r.kernel.org, mgorman@...e.de, rientjes@...gle.com,
aneesh.kumar@...ux.vnet.ibm.com, hughd@...gle.com,
hannes@...xchg.org, mhocko@...e.cz, boaz@...xistor.com,
raindel@...lanox.com
Subject: Re: [RESEND RFC v4 2/3] mm: make optimistic check for swapin
readahead
On 09/03/2015 10:51 PM, Ebru Akagunduz wrote:
> This patch introduces new sysfs integer knob
> /sys/kernel/mm/transparent_hugepage/khugepaged/max_ptes_swap
> which makes optimistic check for swapin readahead to
> increase thp collapse rate. Before getting swapped
> out pages to memory, checks them and allows up to a
> certain number. It also prints out using tracepoints
> amount of unmapped ptes.
>
> Signed-off-by: Ebru Akagunduz <ebru.akagunduz@...il.com>
...
> #include <asm/pgalloc.h>
> @@ -49,7 +50,8 @@ static const char *const khugepaged_status_string[] = {
> "page_swap_cache",
> "could_not_delete_page_from_lru",
> "alloc_huge_page_fail",
> - "ccgroup_charge_fail"
> + "ccgroup_charge_fail",
> + "exceed_swap_pte"
> };
>
> enum scan_result {
> @@ -73,7 +75,8 @@ enum scan_result {
> SCAN_SWAP_CACHE_PAGE,
> SCAN_DEL_PAGE_LRU,
> SCAN_ALLOC_HUGE_PAGE_FAIL,
> - SCAN_CGROUP_CHARGE_FAIL
> + SCAN_CGROUP_CHARGE_FAIL,
> + MM_EXCEED_SWAP_PTE
This one should be renamed too.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists