[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20150911154730.3a2151a0b111fed01acdaaa1@linux-foundation.org>
Date: Fri, 11 Sep 2015 15:47:30 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Xishi Qiu <qiuxishi@...wei.com>
Cc: Andrey Konovalov <adech.fo@...il.com>,
Rusty Russell <rusty@...tcorp.com.au>,
Michal Marek <mmarek@...e.cz>,
"long.wanglong" <long.wanglong@...wei.com>,
Linux MM <linux-mm@...ck.org>,
LKML <linux-kernel@...r.kernel.org>,
Andrey Ryabinin <ryabinin.a.a@...il.com>
Subject: Re: [PATCH] kasan: use IS_ALIGNED in memory_is_poisoned_8()
On Fri, 11 Sep 2015 10:02:29 +0800 Xishi Qiu <qiuxishi@...wei.com> wrote:
> Use IS_ALIGNED() to determine whether the shadow span two bytes.
> It generates less code and more readable.
>
Please cc Andrey Ryabinin on kasan patches.
> --- a/mm/kasan/kasan.c
> +++ b/mm/kasan/kasan.c
> @@ -120,7 +120,7 @@ static __always_inline bool memory_is_poisoned_8(unsigned long addr)
> if (memory_is_poisoned_1(addr + 7))
> return true;
>
> - if (likely(((addr + 7) & KASAN_SHADOW_MASK) >= 7))
> + if (likely(IS_ALIGNED(addr, 8)))
> return false;
Wouldn't IS_ALIGNED(addr, KASAN_SHADOW_SCALE_SIZE) be more appropriate?
But I'm not really sure what the original code is trying to do.
if ((addr + 7) & 7) >= 7)
can only evaluate true if ((addr + 7) & 7) equals 7, so the ">=" could
be "==".
I think. The code looks a bit weird. A code comment would help.
And how come memory_is_poisoned_16() does IS_ALIGNED(addr, 8)? Should
it be 16?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists