[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <BY2PR0301MB165498EE3FC07D57AE99A984A05C0@BY2PR0301MB1654.namprd03.prod.outlook.com>
Date: Tue, 15 Sep 2015 23:27:29 +0000
From: KY Srinivasan <kys@...rosoft.com>
To: Jake Oshins <jakeo@...rosoft.com>,
"gregkh@...uxfoundation.org" <gregkh@...uxfoundation.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"devel@...uxdriverproject.org" <devel@...uxdriverproject.org>,
"olaf@...fle.de" <olaf@...fle.de>,
"apw@...onical.com" <apw@...onical.com>,
"vkuznets@...hat.com" <vkuznets@...hat.com>,
"linux-pci@...r.kernel.org" <linux-pci@...r.kernel.org>,
"bhelgaas@...gle.com" <bhelgaas@...gle.com>,
"tglx@...utronix.de" <tglx@...utronix.de>
CC: Jake Oshins <jakeo@...rosoft.com>
Subject: RE: [PATCH v2 06/12] drivers:hv: Export do_hypercall()
> -----Original Message-----
> From: jakeo@...rosoft.com [mailto:jakeo@...rosoft.com]
> Sent: Thursday, September 10, 2015 5:01 PM
> To: gregkh@...uxfoundation.org; KY Srinivasan <kys@...rosoft.com>; linux-
> kernel@...r.kernel.org; devel@...uxdriverproject.org; olaf@...fle.de;
> apw@...onical.com; vkuznets@...hat.com; linux-pci@...r.kernel.org;
> bhelgaas@...gle.com; tglx@...utronix.de
> Cc: Jake Oshins <jakeo@...rosoft.com>
> Subject: [PATCH v2 06/12] drivers:hv: Export do_hypercall()
>
> From: Jake Oshins <jakeo@...rosoft.com>
>
> This patch exposes the function that hv_vmbus.ko uses to make hypercalls.
> This
> is necessary for retargeting an interrupt when it is given a new affinity.
>
> Signed-off-by: Jake Oshins <jakeo@...rosoft.com>
> ---
> drivers/hv/hv.c | 3 ++-
> include/linux/hyperv.h | 1 +
> 2 files changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/hv/hv.c b/drivers/hv/hv.c
> index 6341be8..6d01649 100644
> --- a/drivers/hv/hv.c
> +++ b/drivers/hv/hv.c
> @@ -91,7 +91,7 @@ static int query_hypervisor_info(void)
> /*
> * do_hypercall- Invoke the specified hypercall
> */
> -static u64 do_hypercall(u64 control, void *input, void *output)
> +u64 do_hypercall(u64 control, void *input, void *output)
do_hypercall() is not an appropriate name for a function to be exported. I plan to take the base
vmbus patches through Greg's tree and if it is ok with you, I will change the name of this function.
Regards,
K. Y
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists